I'm trying to start a Wicket Application using Felix implementation of
OSGi HTTP service, for that I just register the service using
WicketServlet with applicationClassName parameter set to the main
application class name:

props.put("applicationClassName", MainApplication.class.getName());
service = (HttpService)context.getService(httpReference);
service.registerServlet("/", new WicketServlet(), props, null);

But it fails to register saying that wicket is "Unable to create
application of class es.warp.sample.HTTPLocalGUI.MainApplication".
The output error also includes some lines about class loader so I
thought it was something related with visibility. I tried to export
everything but I had the same failure.
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:247)

I use for deployment maven and pax runner with Felix framework (mvn
package install pax:run -Dframework=felix -Dprofiles=log,config).
If I use equinox instead of felix, the application is registered and
works perfectly, it's ok for development, but I need it working on
felix for production deployment.

I'm thinking that I'm not doing it on the right way, but I don't know
how to do it. I also tried to publish the servlet using Felix
Whiteboard service, and I had the same results, it worked when I used
equinox and it didn't work when I used felix.

What am I doing wrong?



To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to