I'm trying to do functional tests using Selenium IDE.

I did 
getDebugSettings().setOutputComponentPath(true);

to solve the problem with dynamic ids.
see also: 
http://www.inforw.de/content/doku.php/blog/300


It works for most actions in my application, but after recording the usage
of DropDownChoice components 
the test run crashes with an error (input not found)
See log output below. The component selPredef, which is a DropDowChoice is
not resolved to wicketpath, but still using an ID. Why??


# [info] Executing: |click |
//input[@wicketpath='tabs_panel_lnkTermsAdmin_dlgPlaceHolderTerms_content_form_btnSave']
| |
# [info] Executing: |click |
//span[@wicketpath='tabs_panel_lnkCountriesAdmin_lblCountries'] | |
# [info] Executing: |click |
//input[@wicketpath='tabs_panel_lnkCountriesAdmin_dlgPlaceHolderCountries_content_form_pnlCheckLabelListDatas_listOfCheckLabels_25_cols_27_chkValue']
| |
# [info] Executing: |click | //div[@id='newselPredef10da']/input | |
# [error] Element //div[@id='newselPredef10da']/input not found 


Is there a solution for my problem ?

Thanks for any hints!

Ralph

--
View this message in context: 
http://apache-wicket.1842946.n4.nabble.com/Selenium-Problem-tp3514063p3514063.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to