Emond,

Finally I can make it run in Firefox by disable using websocket in web.xml


<init-param>
            <param-name>org.atmosphere.useWebSocket</param-name>
            <param-value>false</param-value>
        </init-param>


Don't know if there's drawback doing that since it comes as default setting in 
the quickstart. 


Regards,
Noven


________________________________
 From: Emond Papegaaij <emond.papega...@gmail.com>
To: users@wicket.apache.org; Noven <noven_...@yahoo.com> 
Sent: Thursday, December 27, 2012 2:29 PM
Subject: Re: Wicket Atmosphere does not run in Firefox 17
 
It seems you hosting provider does not support websockets. For some reason,
in Chrome the downgrade to 'streaming' works fine, but in Firefox it does
not. Firefox keeps trying to establish a ws connection, which fails over
and over again. I think this is a problem in Atmosphere. You could try
asking this question at their google groups. I've created a ticket
(WICKET-4946) for passing parameters to atmosphere, which would allow you
to disable websocket.

Best regards,
Emond Papegaaij


On Mon, Dec 24, 2012 at 12:22 PM, Noven <noven_...@yahoo.com> wrote:

>
> Hi,
>
> Thank you for your reply before. I did not change anything in firefox. If
> I have to, I can't use this feature.
> I doubt if the problem caused from firefox. When the quickstart deployed
> in my localhost (both tomcat and jetty), it run well in firefox.
>
>
> ________________________________
>  From: Andreas Kuhtz <andreas.ku...@gmail.com>
> To: users@wicket.apache.org; Noven <noven_...@yahoo.com>
> Sent: Monday, December 24, 2012 5:21 PM
> Subject: Re: Wicket Atmosphere does not run in Firefox 17
>
>
> Hi,
>
> Have you configured a proxy in firefox? if so, you may enable the "ws://*"
> to use the proxy, not only http and https.
> Hope this helps.
>
> Cheers
>
>
> 2012/12/24 Noven <noven_...@yahoo.com>
>
> Hi All,
> >
> >I just tried deploy the wicket-atmosphere-quickstart here at
> http://api.bola54.com into tomcat v.7.0.32
> >
> >It's able run well on safari and chrome, but fail run on newest firefox
> v.17.
> >
> >By using the same tomcat version, I am able to run it on firefox v.17 in
> my localhost but failed at http://api.bola54.com.
> >
> >
> >Did anybody know this issue before?
> >
> >
> >Thank you.
>

Reply via email to