Hi all,

in a webapp that worked until yesterday (and that has worked for the last
2 years), the AuthenticatedWebSession.authenticate() method is not being
called anymore. I have MySession class that extends
AuthenticatedWebSession. The MySession constructor gets called correctly.
I use a standard SignInPanel: when I click "Sign in" the page reloads but
the code execution doesn't reach the breakpoint at the first line of
authenticate() in MySession. The authenticate() method does have the
@Override annotation, so I'm sure it has the correct signature.

Changes I've made since yesterday are only to the css, some HTML, a few
new initParameters in web.xml, but nothing directly related to the login
process... any clue about what could be causing that behavior? What should
I check first?

Btw, no, I didn't commit the code yesterday before those changes, so now I
can't revert, my bad.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to