Hello, I have a weird issue in my tests. I have a html file with that line :



wich is supposed to add a question circle in my page.
When I run my tests, I do :

public void testWicketExist() throws Exception {
        // GIVEN : Page was created
        // Page creation
        ModuleCreatePanel panel = new ModuleCreatePanel("test", new
PageParameters());
        // WHEN : render a module table panel
        panel = this.tester.startComponentInPage(panel);
        WicketHelper.printChildrenTree(this.tester.getLastRenderedPage());
        // THEN : check the value in the attribute
        WicketHelper
                .assertAttribute(
                        "link must have the expected class!",
                        "fa fa-question-circle",
                        this.tester
                               
.getComponentFromLastRenderedPage("test:newModulePanel:moduleCreateForm:address-helper"),
                        "class");
    }

But the WicketHelper.assertAttribute can't find it. Would you know why ?
(the path is fine, I displayed it with
WicketHelper.printChildrenTree(this.tester.getLastRenderedPage()); )

--
View this message in context: 
http://apache-wicket.1842946.n4.nabble.com/Problem-Attribute-not-found-tp4667711.html
Sent from the Users forum mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to