I have a page that takes a set of parameters generated by an outside source.  
It's Kiosk software that reads magnetic track data from a card reader device, 
converts it to parameters and generates a request to my page.  Prior to 
upgrading to 1.5, the code below worked to read them, but now these specific  
parameters are null.

    public TrackDataReadClass (PageParameters params) {
        String dataitems = params.get("dataitems").toString();
        String dataStripe1 = params.get("dataitem0").toString();
        String dataStripe2 = params.get("dataitem1").toString();

     etc... }

I've also tried 

        StringValue dataStripe1 = 
RequestCycle.get().getRequest().getPostParameters().getParameterValue("dataStripe1");
 
             (and getRequestParameters)
        

Also, prior to 1.5 HTTP requests were handled directly per the localhost access 
log, but now they're getting redirected:

 - - [05/Jun/2014:10:00:48 -0500] "POST / myapp /app/pages/ TrackDataReadClass 
HTTP/1.1" 200 14574

Vs.

- - [29/Jun/2015:12:02:40 -0500] "POST /myapp/app/pages/TrackDataReadClass 
HTTP/1.1" 302 -
- - [29/Jun/2015:12:02:40 -0500] "GET / myapp /app/wicket/page?2 HTTP/1.1" 200 
2684


Thanks,

Greg


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to