Did you solve this?

I got the same problem when upgrading from 1.1 M4 to 1.1.2. When editing 
global and space rights, the button "add access right entry" in the 
GlobalRightsEditorWelcome panel was missing.

I found a workaround to this by opening the WebPreferences page for the 
space a wanted to add access rights to,  selecting "edit objects", and 
added a  XWiki.XWikiGlobalRights object to the page.

Today, when looking closer into this, I found that this misbehaviour has 
something to do with the $xwiki.rightsmanager.defaultUi variable. This 
variable tells which gui to use for acces management. By inspecting the 
code of the GlobalRightsEditorWelcome panel, I found that the button 
only is showed when the following condition is true:
  #if ($xwiki.rightsmanager.defaultUi == "stable")
But for som reason, this variable was undefined, all though I had 
"xwiki.rights.defaultUi = new" in xwiki.cfg. What is the relationship 
between xwiki.rightsmanager.defaultUi and xwiki.rights.defaultUi ? I 
suspect a typo..  I've never seen the new access right manager in my 
wiki, so there is obviously something wrong here..

However, by modifying the condition:
 #if(!($xwiki.rightsmanager.defaultUi) || $xwiki.rightsmanager.defaultUi 
== "stable")
everything is back to normal.


Vincent Massol wrote:
> On Jan 24, 2008, at 7:47 PM, Aleksandar Vidakovic wrote:
>> I had an idea (but don't know if it's stupid ;-)
>> Anyway... could it be that there is a page missing in my space. When I
>> edit the space rights I get this URL:
>> http://localhost:8080/xwiki/bin/admin/XXXX/WebPreferences?editor=spacerights&global=1&space=XXXX
>> As there is a page "WebPreferences" in the XWiki space (and this one
>> allows me to edit rights) I would expect the same page in my space  
>> XXXX.
> This WebPreferences page is created automatically by the Admin page  
> when you start setting space rights.
> I've just tried with a vanilla 1.2 release and it worked fine for me  
> so it could be related to your environment somehow.
> -Vincent
>> Completely wrong?
>> Thanks again for your help...
>> Aleks
>> Aleksandar Vidakovic wrote:
>>> No, I don't have this plugin installed. Installed plugins are:
>>> - Chatzilla
>>> - delicious
>>> - gTranslate
>>> - Download Statusbar
>>> - Firebug
>>> - Google Gears
>>> - Google Reader Watcher
>>> - Googlepedia
>>> - Scribefire
>>> - Webdeveloper
>>> Esbach, Brandon wrote:
>>>> Sorry, should have made myself clearer.
>>>> I noticed you were using Firefox, and was just clarifying whether  
>>>> you
>>>> use the Firefox plugin called NoScript (check this by going to  
>>>> Tools ->
>>>> Add-ons).
>>>> The rights editor on Xwiki uses Ajax, which is essentially script  
>>>> sent
>>>> to and from the server.
>>>> What NoScript does, is it disables certain javascript functionality
>>>> depending on the address you are browsing, and I've seen it do weird
>>>> stuff with XWiki in the past.
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
users mailing list

Reply via email to