Hi Roman, hi Sergiu

thanks for your help. 

As Roman wrote, our problem was with system documents.
First we upgraded from 2.1.M1 to 2.2.2  (we upgraded only core, not
documents from default xar) - livetable didn't work well, index page was
empty, also page with livetable for "TestClass" was empty.
Then we upgraded from 2.2.2 to 2.2.3 - same result.
Then I imported documents from default xar for version 2.2.3 (I imported all
documents but -  XWiki.XWikiPreferences,  XWiki.WebPreferences,
XWiki.XWikiAllGroup, XWiki.XWikiAdminGroup)

Problem with empty index page was solved. Index page work well, but with
livetable for "TestClass" I had same problem I have had before. There was
still row for template document in livetable.

Class name is "TestClass", template is "TestTemplate" (it is default name
for template). 
When you are creating class with name Test suffix Class is added, but not
for template.

Filter in LiveTableResultsMacros is ... doc.fullName<>'${className}Template

When I renamed "TestTemplate" to "TestClassTemplate" livetable started work
well,  template document in livetable for TestClass is filtered. 

I assume it is an issue, should I raise Jira issue for  it?

Also if there is a column for TextArea type property in a livetable, table
is empty, but maybe it is a feature not issue.


View this message in context: 
Sent from the XWiki- Users mailing list archive at Nabble.com.
users mailing list

Reply via email to