Hi Marius,
 
thanks for the manual to get nearer to the failure.
 
As a normal user i get this response:
https://intranet.trox.de/xwiki/rest/wikis/intranet/spaces/EB%20Knowledge%20Base/pages/ASIM/attachments?undefined=null&r=628499
401 Unauthorized
As admin:
... 200 OK
 
I suppose the list of attachments is empty for a regular user and not
empty for an admin, right? Yes
All pages are edited and filled by regular users. Admins are only for
administration, they do not work in the pages.
 
Do you have any suggestions?
 
Yours,
Mark


>>> 


Von: Marius Dumitru Florea <mariusdumitru.flo...@xwiki.com>
An:<users@xwiki.org>
Datum: 26.05.2011 11:59
Betreff: Re: [xwiki-users] Antw: Re:  Linking images in the wysiwyg
editor
On 05/26/2011 08:46 AM, Mark Zimmermann wrote:
> Hi Marius,
>
> here you find the picture in a better place.
>
> http://www.trox.de/service/Dialog.png
>
> What happend:
> - An attachment is already uploaded and linked to a wiki page
> - FYI: Files are stored in DB
> - Open a wiki page
> - Choose WYSIWYG Editor
> - Mark a word, click "Link" in the Menu
> - The Link Dialog opens
> - I browse through all Pages in the XWIKI tree
> - I can not find my files (any file in the whole tree)
>
> Note: If the attachments are on the same page, they are displayed,
like
> on the left side, but can not be seen in the tree on the right side

> And if I am logged in as an Administrator, everything works
perfectly.

This suggests that you're having a rights issue. I tested both locally

with a fresh XWiki Enterprise 2.7 and also on a 2.7 XWiki Enterprise 
Manager (which you're using) and I couldn't reproduce your problem. It

would be great if you can use Firefox browser with its Firebug
extension 
to check the response received to the REST request that is supposed to

retrieve the list of attachments:

* open Firebug and go to the console tab (enable it if it is disabled)
* open the link dialog and browse the tree to a document that you know

it has attachments.
* expand the "Attachments" node
* the last request logged in the console should look like:

http://<server>/xwiki/rest/wikis/<subwiki>/spaces/<spaceName>/pages/<pageName>/attachments

Check the XML response. I suppose the list of attachments is empty for
a 
regular user and not empty for an admin, right? You can copy the URL
and 
try it in a separate browser tab/window, once for a regular user and 
once for an admin. Does it happen for all pages, even for pages created

by the regular user and which have files attached by the regular user?

Is there anything logged in the server console when the "Attachments" 
node is expanded?

Hope this helps,
Marius

>
> Thanks,
> Mark
>
>>>>
>
>
> Von: Marius Dumitru Florea<mariusdumitru.flo...@xwiki.com>
> An:<users@xwiki.org>
> Datum: 26.05.2011 00:48
> Betreff: Re: [xwiki-users] Linking images in the wysiwyg editor
> Hi Mark,
>
> This mailing list forbids mail attachments. Could you upload your
image
>
> on a public site? Also, can you detail a bit the steps need to
> reproduce
> the problem? I suppose you are attaching the file to the currently
> edited page, so from the "Current page" tab. Is that right?
>
> Thanks,
> Marius
>
> On 05/25/2011 01:25 PM, Mark Zimmermann wrote:
>> Hello,
>> we are using XWIKI ENTERPRISE 2.7.33656. Attaching of files to a
> wiki
>> page is working properly with the WYSIWYG editor.
>> If I want to link to the attached file another time from the same
>> location or another location i do not see the file in the document
> tree
>> of the link window. No file is displayed here, but if the file is
> stored
>> on the same page it is only displayed in the first tab of this
> dialog.
>> For better understanding, there is an image of these dialogs
> attached.
>> Thanks for any help.
>> Yours, Mark
>>
>> _______________________________________________
>> TROX GmbH
>> Heinrich-Trox-Platz, 47504 Neukirchen-Vluyn
>> Amtsgericht Kleve, HRB 4997
>>
>> Geschäftsführung:
>> Udo Brinkmann, Lutz Reuter
>>
>> Aufsichtsrat:
>> Dr. Wilhelm Dettmering (Vorsitzender)
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users@xwiki.org
>> http://lists.xwiki.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
> _______________________________________________
> TROX GmbH
> Heinrich-Trox-Platz, 47504 Neukirchen-Vluyn
> Amtsgericht Kleve, HRB 4997
>
> Geschäftsführung:
> Udo Brinkmann, Lutz Reuter
>
> Aufsichtsrat:
> Dr. Wilhelm Dettmering (Vorsitzender)
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
TROX GmbH
Heinrich-Trox-Platz, 47504 Neukirchen-Vluyn
Amtsgericht Kleve, HRB 4997

Geschäftsführung:
Udo Brinkmann, Lutz Reuter

Aufsichtsrat:
Dr. Wilhelm Dettmering (Vorsitzender)
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to