On Thu, Jul 7, 2011 at 2:59 AM, Marius Dumitru Florea
<mariusdumitru.flo...@xwiki.com> wrote:
> On 07/06/2011 05:59 PM, Rob Gillen wrote:
>> On Wed, Jul 6, 2011 at 2:58 AM, Marius Dumitru Florea
>> <mariusdumitru.flo...@xwiki.com>  wrote:
>
> [snip]
>
>>
>> I never saw anything quite that simple.  I did see a "menu"
>> associative array (hash) key used in a javascript variable named
>> "wysiwygConfigdJG4".  Here's the relevant key/value:
>>
>> menu: 
>> '[{\"feature\":\"link\",\"subMenu\":[\"linkEdit\",\"linkRemove\",\"linkWikiPage\",\"linkAttachment\",\"|\",\"linkWebPage\",\"linkEmail\",\"|\",\"alfrescoLink\"]},{\"feature\":\"image\",\"subMenu\":[\"imageInsertAttached\",\"imageInsertURL\",\"imageEdit\",\"alfrescoImage\",\"imageRemove\"]},{\"feature\":\"table\",\"subMenu\":[\"inserttable\",\"insertcolbefore\",\"insertcolafter\",\"deletecol\",\"|\",\"insertrowbefore\",\"insertrowafter\",\"deleterow\",\"|\",\"deletetable\"]},{\"feature\":\"macro\",\"subMenu\":[\"macroInsert\",\"macroEdit\",\"|\",\"macroRefresh\",\"|\",\"macroCollapse\",\"macroExpand\"]},{\"feature\":\"import\",\"subMenu\":[\"importOffice\"]}]'
>>
>
> This is the issue. The menu configuration has been changed in 3.1M2 (see
> http://www.xwiki.org/xwiki/bin/view/ReleaseNotes/ReleaseNotesXWikiEnterprise31M2#HWYSIWYGEditorConfiguration
> ). I suppose you have imported the Milestone 2 XAR instead of Milestone 1.
>
> The M1 XAR can be found here
> http://maven.xwiki.org/releases/org/xwiki/enterprise/xwiki-enterprise-wiki/3.1-milestone-1/

The XAR that I downloaded actually had no milestone markings, and it
was marked as the "stable" 3.1 release from the XWiki download page:

    http://www.xwiki.org/xwiki/bin/view/Main/Download

The link goes to:

    http://forge.ow2.org/project/download.php?group_id=170&file_id=16847

which redirects to (an ultra slow download):

    http://download.forge.objectweb.org/xwiki/xwiki-enterprise-wiki-3.1.xar

According to the checksum (sha1) values, the file is the same as the
file located at this maven repo link:

    
http://maven.xwiki.org/releases/org/xwiki/enterprise/xwiki-enterprise-wiki/3.1/xwiki-enterprise-wiki-3.1.xar

The date on that file is 20-Jun-2011, which is quite a bit newer than
even the 3.1m2 XAR file (i.e. 24-May-2011).  Not sure if someone
messed up on that, but it might be a good idea to change the file to
the correct one in the download page.  Any idea when milestone 2 is
going to arrive?

Thanks for all your help, Marius!

-Rob
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to