The problem occurs even on xwiki default pages rather than on user generated
pages.

I'd like to keep the current wiki running for users so as not to distrupt
them and build up a new separate installation so I can try isolate what the
problem is as you suggest. 

Can install another xwiki using the same mysql but using a differently names
xwiki database? If so how might I config it? 

-----Original Message-----
From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On Behalf Of
Sergiu Dumitriu
Sent: 09 January 2012 14:36
To: XWiki Users
Subject: Re: [xwiki-users] Insert link on wysiwyg editor

On 01/09/2012 09:28 AM, Marius Dumitru Florea wrote:
> I'm sure you have xwiki-platform-wysiwyg-server-3.2.jar (it has been 
> renamed since 2.7.1) because otherwise the WYSIWYG editor wouldn't 
> load at all. If you can insert a macro, which uses GWT-RPC services, 
> then the problem is elsewhere. Could be related to your configuration.
> I would take a clean XE war and redo the installation steps to see at 
> which point the WYSIWYG editor stops working properly.

Could it be the content that's breaking the functionality? Like some
unescaped characters? Some HTTP request dumps (for example from Firebug)
would be helpful.

> Hope this helps,
> Marius
>
> On Mon, Jan 9, 2012 at 4:11 PM, goldring, richard 
> <richard.goldr...@uk.thalesgroup.com>  wrote:
>> I can insert a macro but can't insert an attached image - get the 
>> same error
>> message: "There was an error loading the data".
>>
>> So maybe under
>> /var/apache/tomcat55/webapps/xwiki-enterprise-web-3.2/WEB-INF/lib
>> xwiki-web-gwt-wysiwyg-server .jar is missing (was in Xwiki 2.7.1 
>> version) - is this the jar that I need? Maybe this 'missing' jar is 
>> causing the problem??
>> It's not in the 3.2 war file - how do I get it?
>>
>> -----Original Message-----
>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>> Behalf Of Marius Dumitru Florea
>> Sent: 09 January 2012 10:12
>> To: XWiki Users
>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>
>> As I said, if XWiki.WysiwygEditorConfig page was broken (bad 
>> permission or invalid configuration) then the WYSIWYG editor wouldn't 
>> load at all. I don't see how it can affect only the Recently Modified 
>> and Search tabs of the link to wiki page feature.
>>
>> The code that is called when you open those tabs is in GWT-RPC 
>> services, so Java classes, which can't be affected by a XAR import 
>> (at least I don't see how). There's no wiki/Java macro. All the code is
in the WYSIWYG server jar.
>> Can you insert an image or a macro? If these features work (they also 
>> use GWT-RPC services) then the problem is strictly related to the 
>> code that queries the database. But if you say that the code I pasted 
>> works fine then I don't have any clues..
>>
>> On Mon, Jan 9, 2012 at 11:15 AM, goldring, richard 
>> <richard.goldr...@uk.thalesgroup.com>  wrote:
>>> Wondering if it's a permission problem - when I visit the 
>>> XWiki.WysiwygEditorConfig page (as Admin) I get the following
>>> displayed: This configuration cannot be displayed because it was 
>>> last edited by Admin who doesn't have permission to edit this
>>> page.XWiki.WysiwygEditorConfig:
>>>
>>> -----Original Message-----
>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>> Behalf Of goldring, richard
>>> Sent: 09 January 2012 08:39
>>> To: 'XWiki Users'
>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>
>>> Yes - the code seemed to work fine and listed sall recent page edits 
>>> ... So I'm not sure where to look next ...what code get's called by 
>>> the Link dialog My recent changes abd Search tabs ... Is it a macro?
>>> Which one? All I can think is it might be something to do with 
>>> copying material from the my previous wiki installation???
>>>
>>> -----Original Message-----
>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>> Behalf Of Marius Dumitru Florea
>>> Sent: 09 January 2012 08:30
>>> To: XWiki Users
>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>
>>> On Mon, Jan 9, 2012 at 10:09 AM, goldring, richard 
>>> <richard.goldr...@uk.thalesgroup.com>  wrote:
>>>> Could importing the wiki pages from my older version of Xwiki have 
>>>> overwritten wiki pages that could be causing this issue? (The 
>>>> previous version was the standalone version using Jetty and HSQL).
>>>
>>> I don't see how. You can break the WYSIWYG editor by messing up its 
>>> configuration (XWiki.WysiwygEditorConfig) but then the editor won't 
>>> load at all. You can't break *only* the Recently Modified / Search 
>>> tabs of the link feature. Have you run the code I pasted?
>>>
>>> Hope this helps,
>>> Marius
>>>
>>>> If so what wiki pages do I need to reinstate?
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>>> Behalf Of Marius Dumitru Florea
>>>> Sent: 06 January 2012 12:51
>>>> To: XWiki Users
>>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>>
>>>> Sure, here you go:
>>>>
>>>> ----------8<----------
>>>> {{groovy}}
>>>> import com.xpn.xwiki.web.Utils;
>>>> import java.util.List;
>>>> import org.xwiki.query.Query;
>>>> import org.xwiki.query.QueryManager;
>>>>
>>>> int offset = 0;
>>>> int limit = 20;
>>>>
>>>> String statement = "select distinct doc.space, doc.name, doc.date 
>>>> from XWikiDocument as doc where doc.author = :author order by 
>>>> doc.date desc, doc.space, doc.name"; QueryManager queryManager = 
>>>> Utils.getComponent(QueryManager.class);
>>>> Query query = queryManager.createQuery(statement, Query.HQL); 
>>>> query.setOffset(offset).setLimit(limit);
>>>> query.bindValue("author", xcontext.getUser());
>>>>
>>>> List<Object[]>  results = query.execute(); for (Object[] result :
>>>> results) {
>>>>   println(result[0] + "." + result[1]); } {{/groovy}}
>>>> ---------->8----------
>>>>
>>>> Hope this helps,
>>>> Marius
>>>>
>>>> On Fri, Jan 6, 2012 at 2:46 PM, goldring, richard 
>>>> <richard.goldr...@uk.thalesgroup.com>  wrote:
>>>>> Ah my company's fire wall won't let me see 
>>>>> http://pastebin.com/Yj8kQ3qU  - can you directly email me  a copy 
>>>>> of the code to paste into my wiki page to try ..
>>>>>
>>>>> Thanks.
>>>>>
>>>>> -----Original Message-----
>>>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>>>> Behalf Of goldring, richard
>>>>> Sent: 06 January 2012 12:34
>>>>> To: 'XWiki Users'
>>>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>>>
>>>>>   Thanks will try that on when I get back on Monday ...
>>>>>
>>>>> -----Original Message-----
>>>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>>>> Behalf Of Marius Dumitru Florea
>>>>> Sent: 06 January 2012 12:25
>>>>> To: XWiki Users
>>>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>>>
>>>>> The code used to retrieve the list of recently modified pages is 
>>>>> this 
>>>>> https://github.com/xwiki/xwiki-platform/blob/xwiki-platform-3.2/xw
>>>>> ik
>>>>> i
>>>>> -
>>>>> platfo
>>>>> rm-core/xwiki-platform-wysiwyg/xwiki-platform-wysiwyg-server/src/m
>>>>> ai
>>>>> n
>>>>> /
>>>>> java/o
>>>>> rg/xwiki/wysiwyg/server/internal/wiki/AbstractWikiService.java#L97
>>>>> . You can try to execute it separately in Groovy to see what's the
>>>> problem.
>>>>> You can start with http://pastebin.com/Yj8kQ3qU which works fine 
>>>>> for me (put it in a wiki page).
>>>>>
>>>>> Hope this helps,
>>>>> Marius
>>>>>
>>>>> On Fri, Jan 6, 2012 at 1:43 PM, goldring, richard 
>>>>> <richard.goldr...@uk.thalesgroup.com>  wrote:
>>>>>>   Not that I can see
>>>>>>
>>>>>> -----Original Message-----
>>>>>> From: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] On 
>>>>>> Behalf Of Marius Dumitru Florea
>>>>>> Sent: 06 January 2012 11:29
>>>>>> To: XWiki Users
>>>>>> Subject: Re: [xwiki-users] Insert link on wysiwyg editor
>>>>>>
>>>>>> Is there any exception logged on the server side?
>>>>>>
>>>>>> Thanks,
>>>>>> Marius
>>>>>>
>>>>>> On Fri, Jan 6, 2012 at 12:57 PM, goldring, richard 
>>>>>> <richard.goldr...@uk.thalesgroup.com>  wrote:
>>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> On xwiki enterprise 3.2, tomcat 5.5, mysql 5.5 that I've just
>>>>> installed...
>>>>>>>
>>>>>>> When editing in WYSIWYG editor and select to insert a link get 
>>>>>>> the following error on Link dialog tabs "My recent changes" and
"Search" :
>>>>>>> "There was an error loading the data". The All pages tab works 
>>>>>>> fine and displays all pages in the selected space though.
>>>>>>>
>>>>>>> Does anyone know what's happening and how to get it working??
>>>>>>>
>>>>>>> Thanks.
>>>>>>>
>>>>>>> Richard

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to