Sorry Vincent, sorry Thomas
but I didn't get it.
What do you mean?
The html content is rendered into the page, but without all stylesheet-information.

Am 29.02.2012 10:42, schrieb Thomas Mortagne:
2012/2/29 Grüner Heinrich<gruener.heinr...@googlemail.com>:
Hi,

I created a velocity macro and called it like this.
{{velocity}}
$services.xtestprogress.render()
{{/velocity}}

It happens that all<link/> -Tags inserted in the render method are removed
in the resulting website.
Any ideas?
content generated by velocity is seen as wiki content by default
(unless you use wiki="false" and in this case it's plain text) so
anything that is not wiki syntax is properly escaped. If you want to
insert html content you need to use {{html}} macro.

See http://extensions.xwiki.org/xwiki/bin/view/Extension/HTML+Macro

Thanks, Stefan.

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users



Am 29.02.2012 10:41, schrieb Vincent Massol:
Hi,

On Feb 29, 2012, at 10:38 AM, Grüner Heinrich wrote:

Hi,

I created a velocity macro and called it like this.
{{velocity}}
$services.xtestprogress.render()
{{/velocity}}

It happens that all<link/>  -Tags inserted in the render method are removed in 
the resulting website.
Any ideas?
If you wish to insert HTML you need to use the HTML macro:
http://extensions.xwiki.org/xwiki/bin/view/Extension/HTML+Macro

Thanks
-Vincent



_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to