Hi,

I mentioned they were .xml files because I was describing the package
content. There is no need to edit them in xml form. You can edit them from
the Edit menu, from inside the wiki.

Working "fine from scratch" is a subjective opinion, because you wanted to
work also on subwikis, to have separate menu content for each wiki, one is
done with javascript - the other with vms, etc. so one may think this is
not the "standard" use case, but another, so it might not worked "from
scratch" in your use case.

Thanks,
Caty

On Fri, Sep 21, 2012 at 2:21 PM, Dmitry Bakbardin <haru_mamb...@mail.ru>wrote:

> Hi, Caty,
>
> IMHO, users would appreciate all kind of these hints and customization in
> step-by-step "manual".
> I had an occasion with a very short time to implement "XWiki.org-styled"
> horizontal menu: I installed it, - it didn't work. :-(
> I gave up and installed "non-XWiki.org-styled menu" instead and it worked
> fine "from scratch".
> Editing xml file - fine, but looks not so obvious for less experienced
> users  :-)
>
> Kind Regards,
>
> Dmitry
>
>
> Fri, 21 Sep 2012 13:30:20 +0300 от "Ecaterina Moraru (Valica)" <
> vali...@gmail.com>:
> >
> >
> >
>
>
> >
>
>
>
> >Well you said you managed to put the Menu in all your wikis. How did you
> do
> >
> that?
> >
> >
> What you find in the archive is:
> >
> - WebPreferences.xml page: this sets the skin "xwiki:XWikiOrgCode.Skin" as
> >
> the active skin. The wiki mark "xwiki:" means that the skin is located on
> >
> your main wiki
> >
> >
> - Skin.xml page: it's a standard skin file, with the addition that it has
> >
> the header.vm field overwritten and adds a reference to
> >
> "xwiki:XWikiOrgCode.MenuMacro". Having again the "xwiki:" marks means that
> >
> this uses the file from the main wiki.  One quick fix for your problem is
> >
> instead of "xwiki:XWikiOrgCode.MenuMacro" put
> >
> "{your_subwiki_name}:XWikiOrgCode.MenuMacro" or even simpler
> >
> "XWikiOrgCode.MenuMacro". This means that the path is no longer absolute,
> >
> but relative to your subwiki. Make sure you duplicate on your subwiki the
> >
> "XWikiOrgCode.MenuMacro" page and add any contextual content you want in
> >
> it.
> >
> >
> - MenuMacro.xml page that contains the content of the menu.
> >
> >
> The case described up means that for each subwiki you have you create a
> >
> separate MenuMacro page. The subwikis can share the same skin, or have
> >
> separate skins for each subwikis.
> >
> >
> The other solution I mentioned is going in MenuMacro.xml and writting
> >
> conditions (if, else, context.database, etc.) .
> >
> >
> Thanks,
> >
> Caty
> >
> >
> On Thu, Sep 20, 2012 at 3:58 PM, niko dangl <niko.da...@gmail.com> wrote:
> >
> >
> > oh i thought i could just import the menu tu each wiki and have an
> >
> > independet menu.
> >
> >
> >
> > but one more silly question how can i manage different menu pages for
> each
> >
> > wiki?
> >
> >
> >
> > thanks and regards,
> >
> > niko
> >
> >
> >
> > 2012/9/20 Ecaterina Moraru (Valica) <vali...@gmail.com>:
> >
> > > Well you edit the menu by editing the page where the menu is defined.
> >
> > > If you put the menu on all your subwikis is normal that the links are
> the
> >
> > > same for each wiki, because they all link to the same page (and in a
> page
> >
> > > the content in static).
> >
> > >
> >
> > > If you want different content for your sub wikis: you can write
> >
> > conditions
> >
> > > to display other links depending on your location, or you could have
> >
> > > different menu pages for each sub wiki.
> >
> > >
> >
> > > Thanks,
> >
> > > Caty
> >
> > >
> >
> > > On Thu, Sep 20, 2012 at 2:40 PM, niko dangl <niko.da...@gmail.com>
> >
> > wrote:
> >
> > >
> >
> > >> I managed to get the Menu in all my Wikis but there is something i
> dont
> >
> > >> get.
> >
> > >>
> >
> > >> How can i edit the entries? I mean i know how to edit the Menu but its
> >
> > >> always for the main wiki and i cant change it for each wiki..
> >
> > >> Maybe its just not possible or i dont know how to do it.
> >
> > >>
> >
> > >> could anyone please help?
> >
> > >> thanks and kind regards
> >
> > >>
> >
> > >> 2012/9/13 niko dangl <niko.da...@gmail.com>:
> >
> > >> > Hi Caty,
> >
> > >> >
> >
> > >> > i get the same result when i check
> >
> > >> http://jira.xwiki.org/browse/XWIKI-7016
> >
> > >> >
> >
> > >> > I'm using xwiki 4.2 M2 and got this in the log.
> >
> > >> >
> >
> > >> > 2012-09-13 17:08:02,270
> >
> > >> > [
> >
> > >>
> >
> >
> http://192.168.10.24:8080/just/wiki/template.junese.de/view/Dashboard/WebHome
> >
> > >> ]
> >
> > >> > WARN  c.x.x.XWiki                    - Exception Including Topic
> >
> > >> > xwiki:XWikiOrgCode.MenuMacro
> >
> > >> > com.xpn.xwiki.XWikiException: Error number 9001 in 9: Access to this
> >
> > >> > document is denied: XWikiOrgCode.MenuMacro
> >
> > >> >
> >
> > >> > not sure if its just a problem with access rights or something else
> >
> > >> > but i checked that for like two hours now and dont get it :(
> >
> > >> >
> >
> > >> > 2012/9/13 Ecaterina Moraru (Valica) <vali...@gmail.com>:
> >
> > >> >> Maybe is this bug http://jira.xwiki.org/browse/XWIKI-7016
> >
> > >> >> What version are you using?
> >
> > >> >>
> >
> > >> >> Thanks,
> >
> > >> >> Caty
> >
> > >> >>
> >
> > >> >> On Thu, Sep 13, 2012 at 2:32 PM, niko dangl <niko.da...@gmail.com>
> >
> > >> wrote:
> >
> > >> >>
> >
> > >> >>> hm it seems i didnt really fix it :(
> >
> > >> >>> now if i login as normal user i get the message "Topic
> >
> > >> >>> xwiki:XWikiOrgCode.MenuMacro does not exist".
> >
> > >> >>>
> >
> > >> >>> after removing the blank it was working but i was logged in as
> >
> > >> >>> "global" user for installation and after switching to a normal
> user
> >
> > >> >>> for the subwiki it doesnt work anymore!
> >
> > >> >>> i guess its something within the rights but dont know where.
> >
> > >> >>>
> >
> > >> >>> also asked google but only found an irc archive.
> >
> > >> >>>
> >
> > >> >>> maybe you could help me in this case.
> >
> > >> >>>
> >
> > >> >>> thanks and regards,
> >
> > >> >>> Niko
> >
> > >> >>>
> >
> > >> >>> 2012/9/13 Ecaterina Moraru (Valica) <vali...@gmail.com>:
> >
> > >> >>> > I'm glad you fixed it.
> >
> > >> >>> >
> >
> > >> >>> > Thanks,
> >
> > >> >>> > Caty
> >
> > >> >>> >
> >
> > >> >>> > On Thu, Sep 13, 2012 at 1:16 PM, niko dangl <
> niko.da...@gmail.com
> >
> > >
> >
> > >> >>> wrote:
> >
> > >> >>> >
> >
> > >> >>> >> Ok thats kinda embarrassing and i really feel stupid right
> now..
> >
> > >> >>> >> Had a blank right next to the  XWikiOrgCode.Skin and now its
> >
> > >> working..
> >
> > >> >>> >> but thanks anyway.
> >
> > >> >>> >>
> >
> > >> >>> >> regards,
> >
> > >> >>> >> niko
> >
> > >> >>> >>
> >
> > >> >>> >> 2012/9/13 niko dangl <niko.da...@gmail.com>:
> >
> > >> >>> >> > Hi everyone,
> >
> > >> >>> >> >
> >
> > >> >>> >> > i just created my own farm and try to build a template wiki
> >
> > which
> >
> > >> i
> >
> > >> >>> >> > can use for upcoming wikis.
> >
> > >> >>> >> > now i got some problems with the configuration.
> >
> > >> >>> >> >
> >
> > >> >>> >> > after searching for a menu bar like on xwiki.org i found the
> >
> > >> >>> extension
> >
> > >> >>> >> > which is what i was looking for.
> >
> > >> >>> >> >
> >
> > >> >>> >>
> >
> > >> >>>
> >
> > >>
> >
> >
> http://extensions.xwiki.org/xwiki/bin/download/Extension/Navigation+Menu+Wiki+Macro/XWikiOrgCode.MenuMacro-branch-xwikiorg.1.xar
> >
> > >> >>> >> >
> >
> > >> >>> >> > if i go to the main wiki i can use this menu and it
> works..but
> >
> > on
> >
> > >> my
> >
> > >> >>> >> > subwiki it wont work..
> >
> > >> >>> >> >
> >
> > >> >>> >> > hopefully someone is more experienced in running a farm and
> >
> > culd
> >
> > >> help
> >
> > >> >>> me
> >
> > >> >>> >> out.
> >
> > >> >>> >> > i dont really know where to start now because i checked the
> >
> > >> rights and
> >
> > >> >>> >> > i think its fine.
> >
> > >> >>> >> >
> >
> > >> >>> >> > thanks so far and regards
> >
> > >> >>> >> > Niko
> >
> > >> >>> >> _______________________________________________
> >
> > >> >>> >> users mailing list
> >
> > >> >>> >> users@xwiki.org
> >
> > >> >>> >> http://lists.xwiki.org/mailman/listinfo/users
> >
> > >> >>> >>
> >
> > >> >>> > _______________________________________________
> >
> > >> >>> > users mailing list
> >
> > >> >>> > users@xwiki.org
> >
> > >> >>> > http://lists.xwiki.org/mailman/listinfo/users
> >
> > >> >>> _______________________________________________
> >
> > >> >>> users mailing list
> >
> > >> >>> users@xwiki.org
> >
> > >> >>> http://lists.xwiki.org/mailman/listinfo/users
> >
> > >> >>>
> >
> > >> >> _______________________________________________
> >
> > >> >> users mailing list
> >
> > >> >> users@xwiki.org
> >
> > >> >> http://lists.xwiki.org/mailman/listinfo/users
> >
> > >> _______________________________________________
> >
> > >> users mailing list
> >
> > >> users@xwiki.org
> >
> > >> http://lists.xwiki.org/mailman/listinfo/users
> >
> > >>
> >
> > > _______________________________________________
> >
> > > users mailing list
> >
> > > users@xwiki.org
> >
> > > http://lists.xwiki.org/mailman/listinfo/users
> >
> > _______________________________________________
> >
> > users mailing list
> >
> > users@xwiki.org
> >
> > http://lists.xwiki.org/mailman/listinfo/users
> >
> >
> >
> _______________________________________________
> >
> users mailing list
> >users@xwiki.org
> >http://lists.xwiki.org/mailman/listinfo/users
> >
>
>
>
>
>
>
>
> Kind regards,
>
> Dmitry
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to