Hello,

I have a related issue to that.
It's possible to name a xwiki-document e.g.

ßßßßßßßßäääääööööööüüüüü´´ß09876543212+#-.,

but it's not possible to call on this one again, even not over the document 
index or so. Instead I'll get

Notice
The requested document could not be found.
You can edit this page to create it.

The address-bar shows:
/bin/view/Main/ßßßßßßßßäääääööööööüüüüü´´ß09876543212%2B%23-.%2C

Shouldn't be all special-characters percent-encoded?

Regards,

Josef Haimerl 

> -----Ursprüngliche Nachricht-----
> Von: users-boun...@xwiki.org [mailto:users-boun...@xwiki.org] Im
> Auftrag von Paul Libbrecht
> Gesendet: Donnerstag, 20. Dezember 2012 09:59
> An: XWiki Users
> Betreff: Re: [xwiki-users] Special characters in pagename (URL)
> 
> Hamster,
> 
> in Curriki we do this, basically this zaps all non-ascii chars.
> However, this requires a special page creation ("create a learning resource"
> in our case).
> 
> paul
> 
> 
> Le 20 déc. 2012 à 09:19, Hamster a écrit :
> 
> > To all,
> >
> > My users are driving me crazy...allthough I have stated several times
> > that they must NOT use any special characters in the pagename (URL),
> > they still create pages with special characters. I also don't like any
> > spaces in the URL (which are replaced by a "+")...
> >
> > Is there a way to parse the pagename before it's created and remove
> > any special characters?
> >
> >
> >
> > --
> > View this message in context:
> > http://xwiki.475771.n2.nabble.com/Special-characters-in-pagename-URL-t
> > p7582985.html Sent from the XWiki- Users mailing list archive at
> > Nabble.com.
> > _______________________________________________
> > users mailing list
> > users@xwiki.org
> > http://lists.xwiki.org/mailman/listinfo/users
> 
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to