Hello,

Apache-configuration is:
# non-SSL<VirtualHost *:80 *:8880>   ServerName              
subsubdomain.subdomain.domain.tld    DocumentRoot            
/home/oseserv/apache/htdocs/subsubdomain.subdomain.domain.tld    ErrorDocument  
         500             /error/500.htm    ErrorDocument           503          
   /error/503.htm    ErrorDocument           404             /error/404.htm
    ErrorLog                .....    CustomLog               ......    
CustomLog              ......
    RewriteEngine           On    RewriteOptions          Inherit
    # Proxy routing to backend server    # Only use reverse proxy for security 
reasons   <IfModule proxy_ajp_module>        ProxyRequests       Off        
ProxyErrorOverride  On        ProxyPreserveHost   Off
          ProxyPass           /           ajp://localhost:11009/           
ProxyPassReverse    /           ajp://localhost:11009/
        <Proxy *>            Order           Allow,Deny            Allow        
   from            all        </Proxy>   </IfModule></VirtualHost>



# for SSL<VirtualHost *:443 *:8843>    ServerName               
subsubdomain.subdomain.domain.tld    DocumentRoot            
/home/apacheuser/apache/htdocs/subsubdomain.subdomain.domain.tld    
ErrorDocument           500             /error/500.htm    ErrorDocument         
  503             /error/503.htm    ErrorDocument           404             
/error/404.htm
    ErrorLog               .....    CustomLog               ....    CustomLog   
            .......
    RewriteEngine           On    RewriteOptions          Inherit

    # Proxy routing to backend server    # Only use reverse proxy for security 
reasons    <IfModule proxy_ajp_module>        ProxyRequests       Off        
ProxyErrorOverride  On        ProxyPreserveHost   Off
                ProxyPass /host-manager !                ProxyPass /jmx-console 
 !                ProxyPass /manager      !
        ProxyPass           /favicon.icon.gif        !                ProxyPass 
          /           ajp://localhost:11843/                ProxyPassReverse    
/           ajp://localhost:11843/        RequestHeader set X-Request-Scheme 
https        <Proxy *>            Order           Allow,Deny            Allow   
        from            all        </Proxy>    </IfModule>

=================Apache Access-Log:
my IP :) - - [04/Mar/2013:10:33:20 +0100] "GET 
/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F HTTP/1.1" 401 475 
"https://subsubdomain.subdomain.domain.tld/bin/view/Main/"; "Mozilla/5.0 (X11; 
Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0"=========
With LogLevel debug the Apache-error logs drops out:
[Mon Mar 04 12:19:13 2013] [debug] mod_proxy_ajp.c(45): proxy: AJP: 
canonicalising URL //localhost:11843/bin/login/XWiki/XWikiLogin[Mon Mar 04 
12:19:13 2013] [debug] proxy_util.c(1506): [client 62.156.205.180] proxy: ajp: 
found worker ajp://localhost:11843/ for 
ajp://localhost:11843/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F,
 referer: https://subsubdomain.subdomain.domain.tld/bin/view/Main/[Mon Mar 04 
12:19:13 2013] [debug] mod_proxy.c(998): Running scheme ajp handler (attempt 
0)[Mon Mar 04 12:19:13 2013] [debug] mod_proxy_http.c(1952): proxy: HTTP: 
declining URL 
ajp://localhost:11843/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F[Mon
 Mar 04 12:19:13 2013] [debug] mod_proxy_ajp.c(698): proxy: AJP: serving URL 
ajp://localhost:11843/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F[Mon
 Mar 04 12:19:13 2013] [debug] proxy_util.c(2011): proxy: AJP: has acquired 
connection for (localhost)[Mon Mar 04 12:19:13 2013] [debug] proxy_util.c(206
 7): proxy: connecting 
ajp://localhost:11843/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F
 to localhost:11843[Mon Mar 04 12:19:13 2013] [debug] proxy_util.c(2193): 
proxy: connected /bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F 
to localhost:11843[Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(224): Into 
ajp_marshal_into_msgb[Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(290): 
ajp_marshal_into_msgb: Header[0] [Host] = 
[subsubdomain.subdomain.domain.tld][Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(290): ajp_marshal_into_msgb: Header[1] [User-Agent] = [Mozilla/5.0 
(X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0][Mon Mar 04 
12:19:13 2013] [debug] ajp_header.c(290): ajp_marshal_into_msgb: Header[2] 
[Accept] = 
[text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8][Mon Mar 04 
12:19:13 2013] [debug] ajp_header.c(290): ajp_marshal_into_msgb: Header[3] 
[Accept-Language] = [de-de,en-us;q=0.7,en;q=0.3][Mon Mar 04 12:19:13 2013
 ] [debug] ajp_header.c(290): ajp_marshal_into_msgb: Header[4] 
[Accept-Encoding] = [gzip, deflate][Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(290): ajp_marshal_into_msgb: Header[5] [Referer] = 
[https://subsubdomain.subdomain.domain.tld/bin/view/Main/][Mon Mar 04 12:19:13 
2013] [debug] ajp_header.c(290): ajp_marshal_into_msgb: Header[6] [Cookie] = 
[JSESSIONID=CB89A9944851D1790DED54D0CD2DD0AB.myserver; language=de][Mon Mar 04 
12:19:13 2013] [debug] ajp_header.c(290): ajp_marshal_into_msgb: Header[7] 
[Connection] = [keep-alive][Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(290): ajp_marshal_into_msgb: Header[8] [X-Request-Scheme] = 
[https][Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(450): 
ajp_marshal_into_msgb: Done[Mon Mar 04 12:19:13 2013] [debug] 
mod_proxy_ajp.c(269): proxy: APR_BUCKET_IS_EOS[Mon Mar 04 12:19:13 2013] 
[debug] mod_proxy_ajp.c(274): proxy: data to read (max 8186 at 4)[Mon Mar 04 
12:19:13 2013] [debug] mod_proxy_ajp.c(289): proxy: got 0 bytes of data[Mon
  Mar 04 12:19:13 2013] [debug] ajp_header.c(687): ajp_read_header: 
ajp_ilink_received 04[Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(697): 
ajp_parse_type: got 04[Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(516): 
ajp_unmarshal_response: status = 401[Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(537): ajp_unmarshal_response: Number of headers is = 6[Mon Mar 04 
12:19:13 2013] [debug] ajp_header.c(599): ajp_unmarshal_response: Header[0] 
[Pragma] = [no-cache][Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(599): 
ajp_unmarshal_response: Header[1] [Cache-Control] = [no-cache][Mon Mar 04 
12:19:13 2013] [debug] ajp_header.c(599): ajp_unmarshal_response: Header[2] 
[Expires] = [Wed, 31 Dec 1969 23:59:59 GMT][Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(599): ajp_unmarshal_response: Header[3] [Content-Type] = 
[text/html;charset=UTF-8][Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(609): 
ajp_unmarshal_response: ap_set_content_type done[Mon Mar 04 12:19:13 2013] 
[debug] ajp_header
 .c(599): ajp_unmarshal_response: Header[4] [Content-Language] = [de][Mon Mar 
04 12:19:13 2013] [debug] ajp_header.c(599): ajp_unmarshal_response: Header[5] 
[Content-Length] = [13508][Mon Mar 04 12:19:13 2013] [debug] 
mod_proxy_ajp.c(443): ap_proxy_ajp_request: origin server sent 401 without 
WWW-Authenticate header[Mon Mar 04 12:19:13 2013] [debug] ajp_header.c(687): 
ajp_read_header: ajp_ilink_received 03[Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(697): ajp_parse_type: got 03[Mon Mar 04 12:19:13 2013] [debug] 
ajp_header.c(687): ajp_read_header: ajp_ilink_received 03[Mon Mar 04 12:19:13 
2013] [debug] ajp_header.c(697): ajp_parse_type: got 03[Mon Mar 04 12:19:13 
2013] [debug] ajp_header.c(687): ajp_read_header: ajp_ilink_received 05[Mon Mar 
04 12:19:13 2013] [debug] ajp_header.c(697): ajp_parse_type: got 05[Mon Mar 04 
12:19:13 2013] [debug] mod_proxy_ajp.c(605): proxy: got response from 
127.0.0.1:11843 (localhost)[Mon Mar 04 12:19:13 2013] [debug] 
proxy_util.c(2029): proxy:
  AJP: has released connection for (localhost)




====Tomcat-Logs:
013-03-04 10:32:17,471 
[https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?srid=Gncp3kyx&xredirect=%2Fbin%2Fjsx%2FXWiki%2FTableEdit%3Flanguage%3Dde%26srid%3DGncp3kyx]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 2013-03-04 
10:32:17,472 
[https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?srid=TCoy25MJ&xredirect=%2Fbin%2Fssx%2FXWiki%2FSharePage%3Flanguage%3Dde%26srid%3DTCoy25MJ]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 2013-03-04 
10:32:28,552 
[https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 2013-03-04 
10:33:12,998 [https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWiki
 
Login?srid=NeN4eOMZ&xredirect=%2Fbin%2Fssx%2FXWiki%2FSharePage%3Flanguage%3Dde%26srid%3DNeN4eOMZ]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 2013-03-04 
10:33:13,002 
[https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?srid=U9Lr75ew&xredirect=%2Fbin%2Fjsx%2FXWiki%2FTableEdit%3Flanguage%3Dde%26srid%3DU9Lr75ew]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 2013-03-04 
10:33:20,323 
[https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F]
 WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method 
[com.xpn.xwiki.api.XWiki.parseMessage] in /templates/login.vm@29,33 




> Date: Fri, 22 Feb 2013 14:11:09 +0100> From: guillaume.fenollar@...> To: 
> users@xwiki.org> Subject: Re: [xwiki-users] Antw: configuring url => Apache , 
> Unauthorized> > Hello!> Can you print here the configuration you're using for 
> Apache Reverse Proxy> role?> > Have you looked to the Apache logs? Any 
> interesting thing?> > > 2013/2/22 Ingo Oellers <ingo.oell...@....de>> > > 
> Hi,> > i have an adjacent problem with XWIKI 4.4 on Tomcat 6 and want to> > 
> connect with Apache from frontend:> >> > The xwiki.war was moved to 
> ROOT-context of Tomcat.> > With direct connection to Tomcat XWIKI is working 
> fine.> >> > If i want to go over Apache with 
> https://subsubdomain.subdomain.domain.tld/ i receive well the> > startpage of 
> XWIKI with dashboard.> > But if want to login i receive an URL> >> > 
> https://subsubdomain.subdomain.domain.tld/bin/login/XWiki/XWikiLogin?xredirect=%2Fbin%2Fview%2FMain%2F>
>  > and the messsage> > 401 Unauthorized.> >> > Does somebody have a clue ?> > 
> The problem is the s
 ame with xwiki.war/with ROOT-context and http> > instead of https.> >> > 
Thanks> > Ingo> >
                                          
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to