On Tue, Aug 27, 2013 at 2:56 PM, Clemens Klein-Robbenhaar
<c.robbenh...@espresto.com> wrote:
>
> On 08/26/2013 03:21 PM, Vincent Massol wrote:
> [...]
>>> By the way, is the distribution manager expected to pop up on an upgrade?
>>
>> Yes definitely, see 
>> http://platform.xwiki.org/xwiki/bin/view/Features/DistributionWizard
>>
>
> Ah, but it did not show up for my installation; however the problem was due 
> to a rogue
> /META-INF/MANIFEST.MF which I somewhat forgot when cleaning up my overlay 
> target
> that should only modify a few template pages ... which perfectly explains why 
> the
> distribution wizard did not get invoked for me.
>
> After deleting that file, the one from the xwiki distribution is picked up
> and the DW came up on the first request for me, too.
>
>  However it only upgrades the content of the main wiki, which has the
> "XWiki Enterprise Manager - UI All" installed (in Step 2). The subwikis
> have the "XWiki Enterprise - UI All" installed, however.
>
>  In Step 3 when I am asked to update the current wiki only or all wikis,
> it does not matter what I choose; the DW sends a request to itself
> with parameter values action=COMPLETE_STEP and either upgradeMode=ALLINONE
> or upgradeMode=WIKI.
>
>  In my installation this causes just an empty page as a response,
> which causes the DW to close and the xwiki main page to show up.
>  The subwikis are not updated, but that can be easily fixed
> by going to the "Extension upgrader" and upgrade the
> "XWiki Enterprise - UI All" on the complete farm.
>
> However I guess this is not how it should work ... so I should
> look at the place where my overlay process has broken things a second time.
>

>  Any pointers to what should have happened in third step?

The last step (Extensions) is displayed only if there are invalid
extensions installed, i.e. extensions that _must_ be upgraded in order
to work. So the explanation could be that either:

* XWiki Enterprise - UI All XAR was not detected by the Extension
Manager as an extension installed on your subwikis or
* the Extension Manager thought that the old version of XWiki
Enterprise - UI All works with the new XWiki version, so the upgrade
was optional (i.e. the extension was outdated but not invalid).

Do you remember if XWiki Enterprise - UI All was listed in Extension
Updater administration section under Invalid Extensions or under
Outdated Extensions?

Hope this helps,
Marius

>
> Cheers,
> Clemens
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to