On Sat, Apr 4, 2015 at 12:23 PM, Eduard Moraru <enygma2...@gmail.com> wrote:
> Hi,
>
> The relevant exception in that log is "java.lang.ClassNotFoundException:
> com.xpn.xwiki.plugin.lucene.LucenePlugin". The Lucene Plugin has been
> retired [1] and replaced by the Solr Search application [2].
>
> You are currently getting that exception because you did not properly
> upgrade your xwiki.cfg/xwiki.properties configuration files. They need to
> be upgraded appropriately to the release notes of the versions you are
> upgrading through.
>
> In this particular case, you did not remove from the xwiki.cfg file, inside
> the "xwiki.plugins" section, the reference to LucenePlugin. Once you remove
> it, XWiki should no longer try to load it and you should not get that
> exception message any more.

In this particular case it probably means you kept the current version
when apt-get asked you if you wanted to move to the new one. You
should compare /etc/xwiki/xwiki.cfg and /etc/xwiki/xwiki.cfg.dpkg-dist
(this is the new standard version) files.

>
> Regarding your original issue, try sharing a screenshot with us. Note that
> attachments don`t work on this list, so please use an image upload online
> service and share us the link.
>
> Thanks,
> Eduard
>
> ----------
> [1]
> http://www.xwiki.org/xwiki/bin/view/ReleaseNotes/ReleaseNotesXWiki70M1#HDeprecatedandRetiredprojects
> [2]
> http://extensions.xwiki.org/xwiki/bin/view/Extension/Solr+Search+Application
>
> On Fri, Apr 3, 2015 at 3:39 PM, Georg Hirn <georg.h...@gmail.com> wrote:
>
>> Ok, I have made a apt-get upgrade for xwiki. It did update some packages
>> with no errors, see apt-get log:
>>
>> Log started: 2015-04-03  13:53:45
>> > (Lese Datenbank ... ^M(Lese Datenbank ... 5%^M(Lese Datenbank ...
>> > 10%^M(Lese Datenbank ... 15%^M(Lese Datenbank ... 20%^M(Lese Datenbank
>> ...
>> > 25%^M(Lese Datenbank ... 30%^M(Lese Datenbank ... 35%^M(Lese Datenbank
>> ...
>> > 40%^M(Lese Datenbank ... 45%^M(Lese Datenbank ... 50%^M(Lese Datenbank
>> ...
>> > 55%^M(Lese Datenbank ... 60%^M(Lese Datenbank ... 65%^M(Lese Datenbank
>> ...
>> > 70%^M(Lese Datenbank ... 75%^M(Lese Datenbank ... 80%^M(Lese Datenbank
>> ...
>> > 85%^M(Lese Datenbank ... 90%^M(Lese Datenbank ... 95%^M(Lese Datenbank
>> ...
>> > 100%^M(Lese Datenbank ... 165997 Dateien und Verzeichnisse sind derzeit
>> > installiert.)
>> > Vorbereitung zum Entpacken von
>> > .../xwiki-enterprise-tomcat7-mysql_7.0+1_all.deb ...
>> > Entpacken von xwiki-enterprise-tomcat7-mysql (7.0+1) über (7.0) ...
>> >  * Stopping Tomcat servlet engine tomcat7       ESC[205G ^MESC[199G[ OK ]
>> >  * Starting Tomcat servlet engine tomcat7       ESC[205G ^MESC[199G[ OK ]
>> > Vorbereitung zum Entpacken von
>> > .../xwiki-enterprise-tomcat-common_7.0+1_all.deb ...
>> > Entpacken von xwiki-enterprise-tomcat-common (7.0+1) über (7.0) ...
>> > Vorbereitung zum Entpacken von
>> > .../xwiki-enterprise-mysql-common_7.0+1_all.deb ...
>> > Entpacken von xwiki-enterprise-mysql-common (7.0+1) über (7.0) ...
>> > Vorbereitung zum Entpacken von .../xwiki-enterprise-common_7.0+1_all.deb
>> > ...
>> > Entpacken von xwiki-enterprise-common (7.0+1) über (7.0) ...
>> > xwiki-enterprise-common (7.0+1) wird eingerichtet ...
>> > xwiki-enterprise-tomcat-common (7.0+1) wird eingerichtet ...
>> > xwiki-enterprise-mysql-common (7.0+1) wird eingerichtet ...
>> > dbconfig-common: writing config to /etc/dbconfig-common/xwiki.conf
>> > dbconfig-common: flushing administrative password
>> > xwiki-enterprise-tomcat7-mysql (7.0+1) wird eingerichtet ...
>> >  * Stopping Tomcat servlet engine tomcat7       ESC[205G ^MESC[199G[ OK ]
>> >  * Starting Tomcat servlet engine tomcat7       ESC[205G ^MESC[199G[ OK ]
>> > Log ended: 2015-04-03  13:54:27
>>
>>
>> Then I opened xwiki again but still the same behavior.
>> Don't know if this helps, but here is the output of the catalina.out after
>> restarting tomcat and logging in to xwiki:
>>
>> WARNUNG: Problem with directory [/usr/share/tomcat7/server], exists:
>> > [false], isDirectory: [false], canRead: [false]
>> > Apr 03, 2015 2:18:11 PM org.apache.catalina.startup.ClassLoaderFactory
>> > validateFile
>> > WARNUNG: Problem with directory [/usr/share/tomcat7/shared/classes],
>> > exists: [false], isDirectory: [false], canRead: [false]
>> > Apr 03, 2015 2:18:11 PM org.apache.catalina.startup.ClassLoaderFactory
>> > validateFile
>> > WARNUNG: Problem with directory [/usr/share/tomcat7/shared], exists:
>> > [false], isDirectory: [false], canRead: [false]
>> > Apr 03, 2015 2:18:12 PM org.apache.coyote.AbstractProtocol init
>> > INFORMATION: Initializing ProtocolHandler ["ajp-bio-8009"]
>> > Apr 03, 2015 2:18:12 PM org.apache.catalina.startup.Catalina load
>> > INFORMATION: Initialization processed in 690 ms
>> > Apr 03, 2015 2:18:12 PM org.apache.catalina.core.StandardService
>> > startInternal
>> > INFORMATION: Starting service Catalina
>> > Apr 03, 2015 2:18:12 PM org.apache.catalina.core.StandardEngine
>> > startInternal
>> > INFORMATION: Starting Servlet Engine: Apache Tomcat/7.0.52 (Ubuntu)
>> > Apr 03, 2015 2:18:12 PM org.apache.catalina.startup.HostConfig
>> > deployDescriptor
>> > INFORMATION: Deploying configuration descriptor
>> > /etc/tomcat7/Catalina/localhost/xwiki.xml
>> > 2015-04-03 14:18:41,423 [localhost-startStop-1] WARN
>> >  ltInstalledExtensionRepository - Invalid extension
>> > [org.xwiki.platform:xwiki-platform-search-lucene-ui-6.4.3] on namespace
>> > [wiki:xwiki] (InvalidExtensionException: No compatible extension is
>> > installed for dependency
>> > [org.xwiki.platform:xwiki-platform-search-lucene-api-6.4.3])
>> > 2015-04-03 14:18:41,435 [localhost-startStop-1] INFO
>> >  o.x.s.s.i.EmbeddedSolrInstance - Starting embedded Solr server...
>> > 2015-04-03 14:18:41,435 [localhost-startStop-1] INFO
>> >  o.x.s.s.i.EmbeddedSolrInstance - Using Solr home directory:
>> > [/var/lib/xwiki/data/solr]
>> > 2015-04-03 14:18:44,448 [coreLoadExecutor-5-thread-1] WARN
>> >  o.a.s.c.RequestHandlers        - Multiple requestHandler registered to
>> the
>> > same name: /update ignoring: org.apache.solr.handler.UpdateRequestHandler
>> > 2015-04-03 14:18:46,633 [localhost-startStop-1] INFO
>> >  o.x.s.s.i.EmbeddedSolrInstance - Started embedded Solr server.
>> > Apr 03, 2015 2:18:47 PM org.apache.catalina.startup.HostConfig
>> > deployDirectory
>> > INFORMATION: Deploying web application directory
>> > /var/lib/tomcat7/webapps/ROOT
>> > Apr 03, 2015 2:18:48 PM org.apache.coyote.AbstractProtocol start
>> > INFORMATION: Starting ProtocolHandler ["ajp-bio-8009"]
>> > Apr 03, 2015 2:18:48 PM org.apache.catalina.startup.Catalina start
>> > INFORMATION: Server startup in 36179 ms
>> > 2015-04-03 14:19:46,730 [XWiki initialization] INFO
>> >  .HibernateDataMigrationManager - Storage schema updates and data
>> > migrations are enabled
>> > 2015-04-03 14:19:47,071 [XWiki initialization] INFO
>> >  .HibernateDataMigrationManager - No data migration to apply for wiki
>> > [xwiki] currently in version [70000]
>> > 2015-04-03 14:19:47,071 [XWiki initialization] INFO
>> >  .HibernateDataMigrationManager - Checking Hibernate mapping and updating
>> > schema if needed for wiki [xwiki]
>> > 2015-04-03 14:19:48,588 [XWiki initialization] ERROR
>> > c.x.x.p.XWikiPluginManager     - Cannot initialize plugin
>> > [com.xpn.xwiki.plugin.lucene.LucenePlugin]. This plugin will not be
>> > available.
>> > java.lang.ClassNotFoundException:
>> com.xpn.xwiki.plugin.lucene.LucenePlugin
>> >         at
>> > org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:193)
>> > ~[xwiki-commons-classloader-api-7.0.jar:na]
>> >         at
>> > org.xwiki.classloader.URIClassLoader$1.run(URIClassLoader.java:180)
>> > ~[xwiki-commons-classloader-api-7.0.jar:na]
>> >         at java.security.AccessController.doPrivileged(Native Method)
>> > ~[na:1.7.0_75]
>> >         at
>> > org.xwiki.classloader.URIClassLoader.findClass(URIClassLoader.java:179)
>> > ~[xwiki-commons-classloader-api-7.0.jar:na]
>> >         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>> > ~[na:1.7.0_75]
>> >         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>> > ~[na:1.7.0_75]
>> >         at
>> >
>> org.xwiki.classloader.xwiki.internal.ContextNamespaceURLClassLoader.loadClass(ContextNamespaceURLClassLoader.java:177)
>> > ~[xwiki-platform-classloader-xwiki-7.0.jar:na]
>> >         at java.lang.Class.forName0(Native Method) ~[na:1.7.0_75]
>> >         at java.lang.Class.forName(Class.java:274) ~[na:1.7.0_75]
>> >         at
>> >
>> com.xpn.xwiki.plugin.XWikiPluginManager.addPlugin(XWikiPluginManager.java:82)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at
>> >
>> com.xpn.xwiki.plugin.XWikiPluginManager.addPlugins(XWikiPluginManager.java:118)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at com.xpn.xwiki.XWiki.preparePlugins(XWiki.java:1161)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:872)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at com.xpn.xwiki.XWiki.initXWiki(XWiki.java:786)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at com.xpn.xwiki.XWiki.<init>(XWiki.java:775)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at
>> >
>> com.xpn.xwiki.internal.XWikiInitializerJob.runInternal(XWikiInitializerJob.java:115)
>> > [xwiki-platform-legacy-oldcore-7.0.jar:na]
>> >         at
>> > org.xwiki.job.internal.AbstractJob.runInContext(AbstractJob.java:209)
>> > [xwiki-commons-job-7.0.jar:na]
>> >         at org.xwiki.job.internal.AbstractJob.run(AbstractJob.java:192)
>> > [xwiki-commons-job-7.0.jar:na]
>> >         at java.lang.Thread.run(Thread.java:745) [na:1.7.0_75]
>> > 2015-04-03 14:19:51,311 [XWiki Solr index job thread] INFO
>> >  o.x.s.s.i.j.IndexerJob         - Starting job of type [solr.indexer]
>> with
>> > identifier [[solr, indexer]]
>> > 2015-04-03 14:19:51,956 [XWiki Solr index job thread] INFO
>> >  o.x.s.s.i.j.IndexerJob         - 0 documents added, 0 deleted and 0
>> > updated during the synchronization of the Solr index.
>> > 2015-04-03 14:19:51,956 [XWiki Solr index job thread] INFO
>> >  o.x.s.s.i.j.IndexerJob         - Finished job of type [solr.indexer]
>> with
>> > identifier [[solr, indexer]]
>> > 2015-04-03 14:20:30,602 [
>> >
>> https://wiki.severina-info.at/xwiki/bin/jsx/GoogleApps/JSExtension?language=de
>> ]
>> > WARN  o.x.v.i.DefaultVelocityEngine  - Deprecated usage of method
>> > [com.xpn.xwiki.web.XWikiMessageTool.get] in
>> > 55:xwiki:GoogleApps.JSExtension@15,232
>>
>>
>>  Can you find anything? Or should I uninstall xwiki and install it again?
>>
>>
>> 2015-04-03 13:22 GMT+02:00 Thomas Mortagne <thomas.morta...@xwiki.com>:
>>
>> > You should have it at the bottom on
>> >
>> >
>> http://yourhost/xwiki/bin/admin/XWiki/XWikiPreferences?editor=globaladmin&section=Presentation
>> > .
>> > If you don't then it means you did not finished your upgrade
>> >  and that may be why you have issues.
>> >
>> > On Fri, Apr 3, 2015 at 12:53 PM, Georg Hirn <georg.h...@gmail.com>
>> wrote:
>> > > I'm sorry but i can't find any option like "icon theme".
>> > > Am I in the wrong dialog(see the screenshots in the attachments)?
>> > >
>> > > 2015-04-03 12:27 GMT+02:00 Georg Hirn <georg.h...@gmail.com>:
>> > >
>> > >> I'm sorry but i can't find any option like "icon theme".
>> > >> Am I in the wrong dialog(see the screenshots in the attachments)?
>> > >>
>> > >> 2015-04-03 11:32 GMT+02:00 Marius Dumitru Florea <
>> > >> mariusdumitru.flo...@xwiki.com>:
>> > >>
>> > >>> On Thu, Apr 2, 2015 at 12:12 AM, Georg Hirn <georg.h...@gmail.com>
>> > wrote:
>> > >>> > Hi,
>> > >>> >
>> > >>>
>> > >>> > I have changed the skin of my xwiki(6.4.3) installation from
>> calibri
>> > to
>> > >>> > flamingo.
>> > >>>
>> > >>> Flamingo is the default skin since XWiki 6.2 so why did you have to
>> > >>> switch from Colibri? Did you do an upgrade from a previous version (<
>> > >>> 6.2)? It's always important to mention if the problem is on a clean
>> > >>> install or after an upgrade.
>> > >>>
>> > >>> Thanks,
>> > >>> Marius
>> > >>>
>> > >>> > When I refreshed the page there were some errors. On some buttons
>> > >>> > the icons were drawn multiple, see the picture in the attachment.
>> > >>> > I tired to update to the latest stable xwiki version (7.0) but
>> > nothing
>> > >>> > changed.
>> > >>> > Could anybody help me please?
>> > >>> >
>> > >>> > Thanks,
>> > >>> > Georg
>> > >>> > _______________________________________________
>> > >>> > users mailing list
>> > >>> > users@xwiki.org
>> > >>> > http://lists.xwiki.org/mailman/listinfo/users
>> > >>> _______________________________________________
>> > >>> users mailing list
>> > >>> users@xwiki.org
>> > >>> http://lists.xwiki.org/mailman/listinfo/users
>> > >>>
>> > >>
>> > >>
>> > > _______________________________________________
>> > > users mailing list
>> > > users@xwiki.org
>> > > http://lists.xwiki.org/mailman/listinfo/users
>> >
>> >
>> >
>> > --
>> > Thomas Mortagne
>> > _______________________________________________
>> > users mailing list
>> > users@xwiki.org
>> > http://lists.xwiki.org/mailman/listinfo/users
>> >
>> _______________________________________________
>> users mailing list
>> users@xwiki.org
>> http://lists.xwiki.org/mailman/listinfo/users
>>
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users



-- 
Thomas Mortagne
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to