> On 26 May 2016, at 15:08, Mahomed Hussein <maho...@custodiandc.com> wrote:
> 
> Hi Thomas
> 
> Thanks for responding.
> 
> The skin is called "CDCSkin". Which is sometimes shown as "Main.CDCSkin".
> 
> The URL for it is:
> 
> http://xwiki.local:8080/xwiki/bin/view/Main/CDCSkin
> 
> The title of the page is simply "Skin" and the breadcrumbs shows "Home > Skin"
> 
> I have tried the following URLS and none work:
> 
> http://xwiki.local:8080/xwiki/bin/view/Main/?skin=CDCSkin
> http://xwiki.local:8080/xwiki/bin/view/Main/?skin=Main.CDCSkin
> http://xwiki.local:8080/xwiki/bin/view/Main/?skin=Skin

Could it be that your skin  page is a nested page?

Try http://xwiki.local:8080/xwiki/bin/view/Main/?skin=Main.CDCSkin.WebHome

Thanks
-Vincent

> I have also checked in /usr/lib/xwiki/skins and the only directory in there 
> is "flamingo". Though I am pretty sure at some point it was changed so that 
> you didn't have to duplicate the folder, just had to create a "skin" document 
> (not sure document is the right word, but hopefully you know what I mean).
> 
> I've tried a search for "CDCSkin" on the server and it doesn't appear to 
> exist on the filesystem.
> 
> Please let me know if you need any other info and thanks again for your help.
> 
> 
> 
> Kind regards,
> 
> 
> 
> 
> Mahomed Hussein
> Custodian Data Centre
> Email: maho...@custodiandc.com
> http://www.CustodianDC.com
> 
> -----Original Message-----
> From: users [mailto:users-boun...@xwiki.org] On Behalf Of Thomas Mortagne
> Sent: 26 May 2016 13:44
> To: XWiki Users <users@xwiki.org>
> Subject: Re: [xwiki-users] xWiki 8.1 ignoring custom skin
> 
> The only thing that changed I can think of is that there is a default base 
> skin now in xwiki.cfg. Skin that were not indicated any parent skin used to 
> inherit directly from /templates/, maybe that's you issue.
> 
> 
> On Thu, May 26, 2016 at 2:41 PM, Thomas Mortagne <thomas.morta...@xwiki.com> 
> wrote:
>> ?skin= should always work. What and where is your skin exactly ?
>> 
>> On Thu, May 26, 2016 at 2:30 PM, Mahomed Hussein
>> <maho...@custodiandc.com> wrote:
>>> Hi
>>> 
>>> It seems that 8.1 is ignoring my custom skin. I can tell because it isn’t 
>>> loading the skin or any of the overriding .vm files.
>>> 
>>> Even if I use the “Test this Skin” link which specifically specifies the 
>>> ?skin=CDCSkin, it doesn’t make any difference.
>>> 
>>> I have looked through:
>>> http://www.xwiki.org/xwiki/bin/view/ReleaseNotes/ReleaseNotesXWiki81
>>> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Skins
>>> But they weren’t much help.
>>> 
>>> Some screenshots:
>>> https://snag.gy/9ZKXN2.jpg
>>> https://snag.gy/oYN3F4.jpg
>>> 
>>> Any help would be sincerely appreciated. Thanks.
>>> 
>>> 
>>> Kind regards,
>>> 

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to