Hi Edward,

> On 03 Sep 2016, at 13:45, Edward Knyshov <edv...@gmail.com> wrote:
> I'm trying to inject xwiki logger using
> @Inject
> Logger logger;
> But when I start xwiki I get totally broken app and following errors in my
> logs:
> https://gist.github.com/edvorg/f6d5205b51ae32b71faf527d9a80302c
> Has anybody met this before?
> Thanks, Edward.

This could be a classloading issue. JBoss/Wildfly has been to know to be quite 
bad in the past at isolating classloaders by default. What could happen is that 
some plexus version and configuration is done by Wildfly that interferes with 
the XWiki webapp.

I’ve tried to reproduce the issue by downloading and starting xwiki in Wildfly 
10.1.0.Final (servlet only) and hit another classloader problem:

From what I could see the problem is that the javax.xml.bind JAR is not present 
in Wildfly 10.1.0.Final (servlet only). So I downloaded and installed the full 
JavaEE one and it went further (note to self: find and document how to make the 
servlet only version work) but I still got an error:

I was able to solve this by telling Wildfly to disable implicit bean archives, 
see https://docs.jboss.org/author/display/WFLY10/CDI+Reference
I added a META-INF/jboss-all.xml with the following content:

<jboss xmlns="urn:jboss:1.0">
    <weld xmlns="urn:jboss:weld:1.0" require-bean-descriptor="true"/>

Note to self: open a jira issue and commit this to make the XWiki WAR ready for 
wildfly deployment.

Then it worked :) There are of course a lot of warnings but no error.

So I didn’t get your error it seems.


users mailing list

Reply via email to