> On 20 Oct 2016, at 10:05, Pascal BASTIEN <pbasnews-xw...@yahoo.fr> wrote:
> 
>>> 
>>> (%
>> class="plainmessage publish-message" %)((((%
>> class="glyphicon glyphicon-globe" %)$message)))
>> 
>> First this is not fully
>> correct. You need to close the span with (%%).
> 
> haaaaa!
> It's like manage to scratch my back! so pleasurable!
> 
> I need to add that here: 
> http://platform.xwiki.org/xwiki/bin/view/Main/XWikiSyntax

You mean here: 
http://platform.xwiki.org/xwiki/bin/view/Main/XWikiSyntax?syntax=2.1&section=Paragraphs
(that’s the only place that needs fixing from what I see)

You want to send a PR?

Thanks
-Vincent

> <div
>> class="plainmessage publish-message">
>>> <p>
>>> <span
>> class="glyphicon glyphicon-globe">This article
>> was published on 17/10/2016 16:47:06</span>
>>> </p>
>>> 
>> </div>
>>> 
>>> 
>> => span inserted BUT I don't want end of span at the
>> end of the $message
>> 
>> Normally you should have tried this:
>> 
>> (% class="plainmessage
>> publish-message" %)((((% class="glyphicon
>> glyphicon-globe" %)(%%)$message)))
>> 
>> But it won’t work because the span is
>> empty.
>> 
>> So you have 2
>> options:
>> - option 1: you insert some
>> character in the space like a space (you’ll get &nbsp;
>> in the output though)
> 
> yes I confirm this. I have &nbsp; in html output) with
> (% class="plainmessage publish-message" %)((((% class="glyphicon 
> glyphicon-globe" %) (%%)$message)))
> 
>> - option 2: you use
>> the html macro.
>> 
>> It seems
>> from your need that you’re trying to output some specific
>> custom HTML so best is to use the html macro for that.
>> You’ll have better control with it.
> 
> yes but I "improved" blog macro: I will commit it this week i think
> 
> ty
> 
> 

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to