No the macro doesn't work with
same error.

I must try with same couple tomcat/java on my dev server.
I think the problem coming from secure stuff (chroot, acl, reverse proxy, etc.) 
on our data center but i don't know where to search error source :-/

En date de : Mar 29.11.16, Thomas Mortagne <> a écrit :

 Objet: Re: [xwiki-users] code macro/jython-standalone-2.7.0-xwiki-3.jar problem
 À: "Pascal BASTIEN" <>, "XWiki Users" <>
 Date: Mardi 29 novembre 2016, 18h33
 The error you pasted have
 nothing to do with
 plus XWIKI-7984 is specific to
 The code macro works
 well with Tomcat and the setup you indicated is
 pretty standard for XWiki. It's probably a
 Jython or Pygments bug with
 the specific
 content you tried.
 Does the
 macro work with some very simple content like:
 If it work with other content then please
 create a jira issue with the
 content that
 reproduce the error and we will try to reproduce it and
 understand where it come from exactly.
 On Tue, Nov 29, 2016 at 3:55 PM, Pascal BASTIEN
 > Hello,
 > I try to deploy xwiki 8.4 on Tomcat
 8.0.32/ java 1.8.0_74 on our datacenter but I have a issue
 with the code macro:
 > {{code}}
 > My code
 > {{/code}}
 > The page displayed:
 "Failed to execute the [code] macro. Cause: [String
 index out of range: 3]. Click on this message for
 > I pasted the details
 > I tested this way
 > (open jython-standalon jar/extract
 everything in Lib/* and put this in a new jar at the root of
 the jar/put the new ) but it doesn't work.
 > Do you have an idea
 what this problem coming from?
 > (It seem that someone else have same
 > Thxs for any help
 > Pascal

Reply via email to