https://codereview.chromium.org/400523007/diff/1/src/hydrogen.cc
File src/hydrogen.cc (right):
https://codereview.chromium.org/400523007/diff/1/src/hydrogen.cc#newcode6128
src/hydrogen.cc:6128: JSFunction* ctor = IC::GetBuiltinConstructor(
On 2014/07/18 13:12:23, Toon Verwaest wrote:
Can you rename this to GetRootConstructor?
Done.
https://codereview.chromium.org/400523007/diff/1/src/ic.cc
File src/ic.cc (right):
https://codereview.chromium.org/400523007/diff/1/src/ic.cc#newcode924
src/ic.cc:924: isolate()->stub_cache()->Get(*name, map, code->flags());
On 2014/07/18 13:12:23, Toon Verwaest wrote:
Probably should move this closer to where we get the monomorphic /
polymorphic
handlers. For this CL this is fine though.
Ack. The difficulty is that where maybe_handler_ is populated, we don't
have the code flags we need for the megamorphic stub cache lookup.
https://codereview.chromium.org/400523007/diff/1/src/ic.cc#newcode936
src/ic.cc:936: Map::UpdateCodeCache(stub_holder_map, name, code);
On 2014/07/18 13:12:24, Toon Verwaest wrote:
Nice :)
:-)
https://codereview.chromium.org/400523007/
--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
---
You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/d/optout.