http://codereview.chromium.org/242050/diff/1/9 File src/stub-cache.cc (right):
http://codereview.chromium.org/242050/diff/1/9#newcode792 Line 792: Object* LoadPropertyWithInterceptorOnly(Arguments args) { On 2009/09/29 17:13:33, Christian Plesner Hansen wrote: > > They are, but locals like receiver_handle (which, btw, should be probably > > renamed into just receiver) are not, correct? > Yes they should be renamed, good point. In any case they are not used for > anything but creating the CustomArguments so it's safe, and we can't disallow > allocation because the getter might allocate. Good point about possibility of GC. Could we get rid of locals altogether then? E.g. it looks like receiver, holder and data are not used except for CustomArgs ctor, so maybe just drop locals and use CustomArguments args(args[4], JSObject::cast(args[1]), ...)? http://codereview.chromium.org/242050 --~--~---------~--~----~------------~-------~--~----~ v8-dev mailing list [email protected] http://groups.google.com/group/v8-dev -~----------~----~----~----~------~----~------~--~---
