Please take another look

https://codereview.chromium.org/1137703002/diff/60001/src/code-stubs.cc
File src/code-stubs.cc (right):

https://codereview.chromium.org/1137703002/diff/60001/src/code-stubs.cc#newcode462
src/code-stubs.cc:462: static Handle<JSFunction> GetFunction(Isolate*
isolate, const char* name) {
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
Nit: no static inside anonymous namespace.

Done.

https://codereview.chromium.org/1137703002/diff/60001/src/code-stubs.cc#newcode476
src/code-stubs.cc:476: };
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
Remove ; and add empty line before, plus add // namespace comment to
make
cpplint and clang-format happy

Done.

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/access-builder.h
File src/compiler/access-builder.h (right):

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/access-builder.h#newcode69
src/compiler/access-builder.h:69: static FieldAccess
ForSharedFunctionInfo();
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
I think the naming scheme suggests ForJSFunctionSharedFunctionInfo().

Done.

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/access-builder.h#newcode72
src/compiler/access-builder.h:72: static FieldAccess
ForTypeFeedbackVector();
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
ForSharedFunctionInfoTypeFeedbackVector()

Done.

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/js-intrinsic-lowering.cc
File src/compiler/js-intrinsic-lowering.cc (right):

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/js-intrinsic-lowering.cc#newcode200
src/compiler/js-intrinsic-lowering.cc:200:
node->set_op(machine()->Word32Equal());
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
How about

  return Change(node, machine()->Word32Equal(), and_result,
jsgraph()->Int32Constant(1))

here?

Done.

https://codereview.chromium.org/1137703002/diff/60001/src/compiler/js-intrinsic-lowering.cc#newcode474
src/compiler/js-intrinsic-lowering.cc:474: Reduction
JSIntrinsicLowering::Change(Node* node, const Operator* op, Node* a,
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
We don't need this helper?

Done.

https://codereview.chromium.org/1137703002/diff/60001/test/mjsunit/tf-stubs-floor.js
File test/mjsunit/tf-stubs-floor.js (right):

https://codereview.chromium.org/1137703002/diff/60001/test/mjsunit/tf-stubs-floor.js#newcode28
test/mjsunit/tf-stubs-floor.js:28: // Flags: --allow-natives-syntax
--expose-natives-as=builtins --noalways-opt
On 2015/05/08 12:17:07, Benedikt Meurer wrote:
Please move to some subdirectory of test/mjsunit/compiler, i.e.
test/mjsunit/compiler/stubs

Done.

https://codereview.chromium.org/1137703002/

--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
For more options, visit https://groups.google.com/d/optout.

Reply via email to