LGTM. Very good. I'll land it Monday, or possibly Tuesday.


https://chromiumcodereview.appspot.com/9159043/diff/4001/test/mjsunit/regress/regress-1924.js
File test/mjsunit/regress/regress-1924.js (right):

https://chromiumcodereview.appspot.com/9159043/diff/4001/test/mjsunit/regress/regress-1924.js#newcode33
test/mjsunit/regress/regress-1924.js:33: assertThrows("a: break a
a",SyntaxError)
Space after comma (just for readability)

https://chromiumcodereview.appspot.com/9159043/diff/4001/test/mjsunit/regress/regress-1924.js#newcode36
test/mjsunit/regress/regress-1924.js:36: assertThrows("a: break a
var",SyntaxError)
Put a variable name after "var", otherwise it would be a syntax error
anyway.

https://chromiumcodereview.appspot.com/9159043/diff/4001/test/mjsunit/regress/regress-1924.js#newcode41
test/mjsunit/regress/regress-1924.js:41: c: if (0) break c; else {}
You could also test the else branch (it also inherits the label).

https://chromiumcodereview.appspot.com/9159043/

--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev

Reply via email to