http://codereview.chromium.org/10442129/diff/1/src/api.cc File src/api.cc (right):
http://codereview.chromium.org/10442129/diff/1/src/api.cc#newcode1073 src/api.cc:1073: if (!constructor.IsEmpty()) { On 2012/06/04 07:50:32, Sven Panne wrote:
Not exactly related to this CL, but we should really clean up this
naming chaos
(here: IsEmpty vs. is_null)... :-P
Yes. However the IsEmpty method (on the external handle) is part of the external API. So that is more or less set in stone. We could think about syncing the internal name with that. http://codereview.chromium.org/10442129/diff/1/src/objects.cc File src/objects.cc (right): http://codereview.chromium.org/10442129/diff/1/src/objects.cc#newcode2002 src/objects.cc:2002: HandleVector(args, 2)); On 2012/06/04 07:50:32, Sven Panne wrote:
2 => ARRAY_SIZE(args)
Done. http://codereview.chromium.org/10442129/diff/1/src/objects.h File src/objects.h (right): http://codereview.chromium.org/10442129/diff/1/src/objects.h#newcode8089 src/objects.h:8089: DECL_ACCESSORS(compatible, Object) On 2012/06/04 07:50:32, Sven Panne wrote:
The name "compatible" is a bit unclear, something like
"expected_receiver_type"
might be better (although our 80-column rule might hurt then >:-).
Done. I agree, the name bothered me as well, "expected_receiver_type" is much better. http://codereview.chromium.org/10442129/diff/1/test/cctest/test-api.cc File test/cctest/test-api.cc (right): http://codereview.chromium.org/10442129/diff/1/test/cctest/test-api.cc#newcode16601 test/cctest/test-api.cc:16601: printf("InstanceCheckedGetter!\n"); On 2012/06/04 07:50:32, Sven Panne wrote:
Hmmm, do we really need printf in unit tests?
Done. Ooops, forgot to remove that again. http://codereview.chromium.org/10442129/ -- v8-dev mailing list [email protected] http://groups.google.com/group/v8-dev
