lgtm



https://chromiumcodereview.appspot.com/10808011/diff/1/src/factory.cc
File src/factory.cc (right):

https://chromiumcodereview.appspot.com/10808011/diff/1/src/factory.cc#newcode933
src/factory.cc:933: // Return the old descriptor array if there were no
new elements.
nit: outdated comment. Suggestion: s/Return the old/Don't replace the/

https://chromiumcodereview.appspot.com/10808011/diff/1/src/objects-inl.h
File src/objects-inl.h (right):

https://chromiumcodereview.appspot.com/10808011/diff/1/src/objects-inl.h#newcode2126
src/objects-inl.h:2126: Descriptor desc(key, value, details);
nit: I don't like shadowing variables. Can you pick another name for
this (e.g. "descriptor" or "moved_descriptor")?

https://chromiumcodereview.appspot.com/10808011/diff/1/src/objects-inl.h#newcode3511
src/objects-inl.h:3511: for (int i = 1; i <= len; ++i) {
Not sure if it's worth the effort, but we *could* make this check faster
by using an array :-)
Or you could hide it behind FLAG_enable_slow_asserts and/or add a TODO
comment.

https://chromiumcodereview.appspot.com/10808011/

--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev

Reply via email to