Small DBC how to improve this CL.
https://codereview.chromium.org/14471041/diff/1/src/math.js
File src/math.js (right):
https://codereview.chromium.org/14471041/diff/1/src/math.js#newcode220
src/math.js:220: return %NumberImul(x, y);
I think the right way to implement this would be renaming this to
"_MathImul", add kMathImul to INLINE_FUNCTION_LIST instead of
RUNTIME_FUNCTION_LIST_ALWAYS, and implement a
HOptimizedGraphBuilder::GenerateMathImul.
As it is, I am relatively sure that we get some bailouts, though I
haven't tested it.
https://codereview.chromium.org/14471041/
--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
---
You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/groups/opt_out.