On Fri, Nov 15, 2013 at 6:58 AM, Steve Jonghee Yun <yun.jong...@gmail.com>wrote:

> Q: Are there any differences between (**reinterpret_cast*<Object****>(F
>> IELD_ADDR(p, offset))) and (*reinterpret_cast*<Object***>(FIELD_ADDR(p,
>> offset))) ?
>>
>
Let's rename "Object*" to "Foo" and "FIELD_ADDR(p, offset)" to "bar", then
the difference should be obvious:

   *reinterpret_cast<Foo*>(bar)

vs.

   reinterpret_cast<Foo>(bar)

The first variant "looks into" bar, the second one doesn't.

-- 
-- 
v8-users mailing list
v8-users@googlegroups.com
http://groups.google.com/group/v8-users
--- 
You received this message because you are subscribed to the Google Groups 
"v8-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to