Hi Leonid,

It looks like the generated solution set for installation can end up with 
some specs out of order causing this error during validation but prior to 
installation. I have the fixed staged in a PR and it will be within the 
next release:

https://github.com/mitchellh/vagrant/pull/8068

Cheers!

On Thursday, December 1, 2016 at 6:19:46 AM UTC-8, Leonid Belkind wrote:
>
> Guys,
>
> I am new to Vagrant, trying to use it to automate creation and 
> configuration of AWS Instances.
> Installed Version: 1.9.0
> Trying to install vagrant-aws plugin, I am getting the following:
>
> Installing the 'vagrant-aws' plugin. This can take a few minutes...
> C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency.rb:315:in 
> `to_specs': Could not find 'fog-xml' (>= 0) among 45 total gem(s) 
> (Gem::LoadError)
> Checked in 'GEM_PATH=C:/HashiCorp/Vagrant/embedded/gems', execute `gem 
> env` for more information
>         from 
> C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/specification.rb:1311:in
>  
> `block in activate_dependencies'
>         from 
> C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/specification.rb:1300:in
>  
> `each'
>         from 
> C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/specification.rb:1300:in
>  
> `activate_dependencies'
>         from 
> C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/specification.rb:1282:in
>  
> `activate'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/bundler.rb:319:in
>  
> `block in activate_solution'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/bundler.rb:316:in
>  
> `each'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/bundler.rb:316:in
>  
> `activate_solution'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/bundler.rb:244:in
>  
> `internal_install'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/bundler.rb:97:in
>  
> `install'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/plugin/manager.rb:62:in
>  
> `block in install_plugin'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/plugin/manager.rb:72:in
>  
> `call'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/plugin/manager.rb:72:in
>  
> `install_plugin'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/action/install_gem.rb:37:in
>  
> `call'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/action/warden.rb:34:in
>  
> `call'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/action/builder.rb:116:in
>  
> `call'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/action/runner.rb:66:in
>  
> `block in run'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/util/busy.rb:19:in
>  
> `busy'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/action/runner.rb:66:in
>  
> `run'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/command/base.rb:14:in
>  
> `action'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/command/install.rb:32:in
>  
> `block in execute'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/command/install.rb:31:in
>  
> `each'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/command/install.rb:31:in
>  
> `execute'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/plugins/commands/plugin/command/root.rb:66:in
>  
> `execute'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/cli.rb:42:in
>  
> `execute'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/lib/vagrant/environment.rb:308:in
>  
> `cli'
>         from 
> C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.0/bin/vagrant:123:in 
> `<main>'
>
> Indeed, when looking in the vagrant/embedded/gems, the gem named fog-xml 
> is missing.
> Any ideas?
>
> Thanks in advance
> Leonid
>

-- 
This mailing list is governed under the HashiCorp Community Guidelines - 
https://www.hashicorp.com/community-guidelines.html. Behavior in violation of 
those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
--- 
You received this message because you are subscribed to the Google Groups 
"Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to vagrant-up+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/vagrant-up/42d54112-2c29-449c-8b70-11aa1ff3ab39%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to