Hi,
I have been trying to install a vagrant plugin behind a corporate proxy and 
whatever I do I always get the same error:

  SSL_connect returned=1 errno=0 state=error: certificate verify failed 
(https://api.rubygems.org/specs.4.8.gz)

I have tried to use the SSL_CERT_FILE environmental variable, add the 
non-https rubygem.org repository and use another repository altogether. 
I have also tried to revert to an older version (the one that is shipped on 
Ubuntu 16.04) and that is broken in another way.
My company's certificates are already installed in the system and I have 
updated the certificates.

Rubygem works out of the box on my current setup (I have checked by 
updating the installed gems and install a new one).

How can I fix this issue?

Thanks,
Michele

-- 
This mailing list is governed under the HashiCorp Community Guidelines - 
https://www.hashicorp.com/community-guidelines.html. Behavior in violation of 
those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
--- 
You received this message because you are subscribed to the Google Groups 
"Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to vagrant-up+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/vagrant-up/d7aff3b7-8dfb-459c-8832-4fd766b37174%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to