I have a vagrant set up that was built by someone else at my company. Other 
co-workers say it works for them on their (similarly configured) apple 
laptops. When I run vagrant up, I get the following:

=> default: Configuring and enabling network interfaces...
default: SSH address:
default: SSH username: vagrant
default: SSH auth method: private key
==> default: Exporting NFS shared folders...
==> default: Preparing to edit /etc/exports. Administrator privileges 
will be required...
==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!
mount -o vers=3 /vagrant
Stdout from the command:
Stderr from the command:
mount.nfs: requested NFS version or transport protocol is not supported

Here's what I think is the relevant snippet from my VagrantFile:

Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
settings = YAML::load(File.read(configFile))
config.ssh.forward_agent = true
VagrantHelper.setBox(settings['provider'], config)
config.vm.hostname = settings["hostname"]
config.hostsupdater.aliases = settings["hostname-aliases"]
config.vm.network :private_network, ip: settings["ip"]
config.vm.network "forwarded_port", guest: 80, host: 8086
config.vm.network "forwarded_port", guest: 443, host: 8443
config.vm.synced_folder ".", "/vagrant", :type => "nfs", :nfs_udp => false,   
:nfs => { :mount_options => ["dmode=777","fmode=777"], :nfs_version => "3" }, 
id: settings["mount-name"]

I've tried changing the nfs_version (tried version 1-6), that didn't fix 
it. If it's a problem with the NFS version, how do I determine what version 
to use? If it's a problem with the transport protocol, how do I determine 
which value to use.

This mailing list is governed under the HashiCorp Community Guidelines - 
https://www.hashicorp.com/community-guidelines.html. Behavior in violation of 
those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
You received this message because you are subscribed to the Google Groups 
"Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to vagrant-up+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to