On Mon, 18 May 2026 18:21:47 GMT, Chen Liang <[email protected]> wrote:

>> For preview of the serialization implementation cleanup.
>> 
>> See the mainline diff version:
>> https://gist.github.com/a3440f2b9da5111fe20315e59ed17380
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Chen Liang has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Message updated

src/java.base/share/classes/java/io/ObjectStreamClass.java line 848:

> 846:     }
> 847: 
> 848:     boolean isDeserializeConstructor() {

This method name reads a bit odd. Is it "useDeserializeConstructor", 
"hasDeserializeConstructor", "isDeserializeConstructor" or would there exist a 
better name to reflect its purpose?

src/java.base/share/classes/java/io/ObjectStreamClass.java line 881:

> 879:     boolean isInstantiable() {
> 880:         requireInitialized();
> 881:         return (cons != null);

Suggestion:

        return cons != null;

-------------

PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2326#discussion_r3355649246
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2326#discussion_r3355651772

Reply via email to