How did you configure vpopmail?  Paste in your ./configure options.


-----Original Message-----
From: Alan Murrell [mailto:[EMAIL PROTECTED]]
Sent: Friday, August 30, 2002 12:11 AM
Subject: [vchkpw] vchkpw: vpopmail user not found


I posted this earlier to the "bulletin board" archive,
but I wasn't subscribed to the list at the time.  I
don't know if it went out to the list, or just got
added to the archives, so I am posting directly to the
list, just in case.

I installed the latest Qmail, Vpopmail (stable, not
development), and Courier-IMAP (yes, I have
AUTHDAEMONS="vchkpw"), daemontools, and ucspi-tcp,
following the instructions in "Bill's Qmail Toaster

I then created a virtual domain using vadddomain (for
this example, I will use as the
domain). I then added '[EMAIL PROTECTED]',
and got prompted to create a password, which I did.

I sent a test email from my Yahoo! account, and it got
to the mailbox just fine. However, when I attempt to
retrieve the email using any mail client, I keep
getting prompted for the username/password. The
/var/log/maillog says:

vchkpw: vpopmail user not found

I tried deleting then re-adding the domain, however,
it does not seem to work. It seems that I am only able
to either get login working correctly, or mail sent to
the mailbox correctly, but not both together (I was
having the problem before where loging in as the user
was working, but mail was being bounced back saying
"user not know", even though the user *did* exist)

Because '' is not the default
domain, I was using '[EMAIL PROTECTED]' as
the username.

The odd thing is that I can only either:

  1. Be able to authenticate as a virtual user, but
mail sent to the user bounces back as "user unknown"
(I have since learned that this is the case if
Courier0IMAP is running the POP3 service); or
  2. Mail sent to a virtual user reached the mailbox,
but I am unable to authenticat (this seems to occur
when vpopmail is handling the POP3, instead of

I even tried using the Sqwebmail interface, since it
reads the users' mailboxes directly, as opposed to
acting as a POP/IMAP client, but I was still unable to
authenticate (I did not try it with Courier-IMAP
handling the POP service, however).

Your help greatly appreciated,

Alan Murrell <[EMAIL PROTECTED]>

Post your free ad now!

Reply via email to