I run system quotas and use courier-imap.  After a user authenticates,
courier switches ID to that user before execing imapd or pop3d.  All new 
folders created are that of the authenticated user.  If they're created as
root (which imapd should *not* be running as root), then there's a
problem with your configuration somewhere.  The only processes that run
as root are the auth daemons, logger, and couriertcpd.


  > Hi,
  > I've been trying to implement that myself and I've run into the problem of
  > running courier-imap as root.  In a normal vpopmail setup, I run
  > courier-imap as vpopmail so that new directories etc are created as the
  > vpopmail user.  If I have multiple domains under different users I must run
  > courier-imap as root so that it has access to read the different user files.
  > When new subfolders get created, they get created as root and then cannot be
  > deleted or moved and maildrop complains about permissions on the subdirs.
  > Any ideas?
  > Rick
  > ----- Original Message -----
  > From: "Ken Jones" <[EMAIL PROTECTED]>
  > Sent: Tuesday, October 22, 2002 9:58 AM
  > Subject: Re: [vchkpw] vsetuserquota
  > Domain based quotas are not part of vpopmail.
  > It is suggested you use file system quotas can
  > keep each domain under a separate /etc/passwd user
  > home directory. vadddomain -u username domainname.
  > Ken Jones

Reply via email to