Can anyone suggest how to clean up this problem? TIA - Eric.

After a lot of time trying different scenarios, I think this situation
causes qmail/vpopmail to begin relaying.

openbsd 3.1
mysql 3.23.49

Clean Installs:
qmail 1.3
vpopmail 5.8.0

I run perl perl rlytest (from a separate server) with
results: rlytest: relay rejected - final response code.  Regular accessing
the pop and sending the mail don't create a problem.

Then I run this (from the crontab -- a daily report that is standard on
OpenBsd):> /bin/sh /etc/daily 2>&1 | tee /var/log/daily.out | mail -s
"`/bin/hostname` daily output" root

Immediately afterwards:

rlytest: relay accepted - final response code 221   !!!!

Here are the aliases:
./valias -s

And here's the ./configure
           vpopmail 5.3.8
            Current settings

vpopmail directory = /home/vpopmail
               uid = 89
               gid = 89
          ip alias = OFF --enable-ip-alias-domains=n (default)
address extentions = OFF --enable-qmail-ext=n (default)
     roaming users = ON  --enable-roaming-users=y
    tcpserver file = /home/vpopmail/etc/tcp.smtp
    open_smtp file = /home/vpopmail/etc/open-smtp
        user quota = OFF --enable-defaultquota=NOQUOTA default
       auth module = mysql --enable-mysql=y
 mysql replication = OFF --enable-mysql-replication=n default
table optimization = many domains --enable-many-domains=y default
  system passwords = OFF --enable-passwd=n default
      file locking = ON  --enable-file-locking=y default
         file sync = OFF --enable-file-sync=n default disable vdelivermail
     make seekable = ON  --enable-make-seekable=y default
      auth logging = ON  --enable-auth-logging=y default
     mysql logging = OFF --enable-mysql-logging=n default
      clear passwd = ON  --enable-clear-passwd=y (default)
     users big dir = ON  --enable-users-big-dir=y (default)
 valias processing = OFF --enable-valias=n
        pop syslog = show only failure attempts
                     --enable-logging=e default
    default domain =
          auth inc = -I/usr/local/include/mysql
          auth lib = -L/usr/local/lib/mysql  -lmysqlclient -lz

Reply via email to