Title: compiling qmailadmin


i think my case has been brought up earlier but from a different perspective,

im attempting to transfer a qmail/vpopmail/qmailadmin/sqwebmail system
to another machine (from redhat 6.2 to SuSE 8.1)
now when i transfered all the files and binaries and loaded the mysql database

mysql works fine,
qmail works fine,
emlm is in the apropriate path,

but qmailadmin and sqwebmail just do not communicate with mysql, i tried
other remote clients to connect to mysql and tried locally from the shell
and i didnt face any problems, in qmailadmin i keep getting the following error
vsql_getpw: failed select
and sqwebmail is just not able to authenticate.

so i thought of giving up on the old binaries and compiling new ones
[(something that im reluctant of doing because the mailing system was
"customized" by a third party and is version dependant *grrr* well at least
the sqwebmail...)]

QMAIL: i didnt have problems with qmail and configured it to run with INETD
 (im not expecting a heavy load so its enough)

VPOPMAIL: with the redirecting to the correct source paths of libs and headers
                   it compiles and works well and communicates with mysql

EZMLM: i just copied the binaries fom the old system

SQWBMAIL: i just copied the binaries from the old system

as for
QMAILADMIN: well when i attempt to compile i get the following error

gcc  -g -O2  -o qmailadmin  qmailadmin.o alias.o autorespond.o forward.o mailinglist.o user.o util.o auth.o template.o command.o sho

w.o cgi.o limits.o dotqmail.o -L/home/vpopmail/lib -lvpopmail -lnsl -lm -lcrypt
/home/vpopmail/lib/libvpopmail.a(vauth.o): In function `vauth_open_update':
/adm/qmailadmin-1.0.6/vauth.c:108: undefined reference to `mysql_init'
/adm/qmailadmin-1.0.6/vauth.c:111: undefined reference to `mysql_real_connect'
/adm/qmailadmin-1.0.6/vauth.c:115: undefined reference to `mysql_error'
/adm/qmailadmin-1.0.6/vauth.c:121: undefined reference to `mysql_real_connect'
/adm/qmailadmin-1.0.6/vauth.c:1076: undefined reference to `mysql_free_result'
collect2: ld returned 1 exit status
make[2]: *** [qmailadmin] Error 1
make[2]: Leaving directory `/adm/qmailadmin-1.0.6'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/adm/qmailadmin-1.0.6'
make: *** [all-recursive-am] Error 2

now can someone please assist in pointing what is going wrong here and why
is if anyone has a slightest clue with the old binaries just are not able to
communicate with Mysql?? do i need to configure apache or mysql in some
exceptional way for this? (if so i have not seen any threads that would point that)

hoping for some more feedback this time


Reply via email to