Good thing I stopped shaving my head, else I'd have no hair to pull out...

Trying to get SMTP-AUTH working with qmail-1.03, the 0.30 patch from, daemontools, & vpopmail 5.3.9 on OpenBSD 3.2. Tried lots of different stuff last night, nothing worked. Currently, my /service/qmail-smtpd/run file is as follows (aside from linewraps, which are correct in the actual file):


QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`
MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
LOCAL=`head -1 /var/qmail/control/me`
if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" -o -z "$LOCAL" ]; then
echo /var/qmail/supervise/qmail-smtpd/run
exit 1
exec /usr/local/bin/softlimit -m 20000000 \
/usr/local/bin/tcpserver -v -R -l "$LOCAL" -x \
/home/vpopmail/etc/tcp.smtp.cdb -c "$MAXSMTPD" \
-u "$QMAILDUID" -g "$NOFILESGID" 0 smtp /var/qmail/bin/qmail-smtpd \
"$LOCAL" /home/vpopmail/bin/vchkpw /usr/bin/true 2>&1


Running with the file above, I get errors in the log like this:

Dec 3 12:01:43 athena vpopmail[19117]: vchkpw-smtp: vpopmail user not found kit

The user [EMAIL PROTECTED] is able to receive mail no problem.

If I change the run script to use `id -u vpopmail` & `id -g vpopmail` instead, attempts to auth fail with no logging.

I've tried eliminating the variables just to make the script as simple as possible:


exec /usr/local/bin/softlimit -m 20000000 \
/usr/local/bin/tcpserver -v -R -x \
/home/vpopmail/etc/tcp.smtp.cdb -c 25 \
-u 89 -g 89 0 smtp /var/qmail/bin/qmail-smtpd \ /home/vpopmail/bin/vchkpw /usr/bin/true 2>&1


(89:89 is vpopmail:vchkpw)

I have no clue why this is not working & there's a sizeable dent in my forehead that matches the edge of the desk. Anybody care to smack me with the clue-by-four here?


"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety."
-Benjamin Franklin

"...qui desiderat pacem, praeparet bellum"
(...if you would have peace, be prepared for war)
-Flavius Vegetius Renatus

Reply via email to