Ok for the first go around I tried to get this to work using the clear text/flat file stuff. I got the following error:
Dec  8 16:44:22 neo vpopmail[10656]: vchkpw: vpopmail user not found testuser@:
Yea I tried the defualt domain stuff and no it doesn't work. So I tried the mysql route and I get this wonderful error during make:
make[2]: Leaving directory `/usr/local/src/vpopmail-5.2.1/cdb'
make[2]: Entering directory `/usr/local/src/vpopmail-5.2.1'
gcc  -g -O2 -Wall  -o vchkpw  vchkpw.o libvpopmail.a -L/usr/lib/mysql  -lmysqlclient -lz -lnsl -lcrypt -lm
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
make[2]: *** [vchkpw] Error 1
make[2]: Leaving directory `/usr/local/src/vpopmail-5.2.1'
make[1]: *** [all-recursive] Error 1
I saw someone posed this same question back in november with no response. I would much rather use the mysql stuff. I am running redhat 7.3. Anyone have any ideas???
 ./configure --enable-mysql=y --enable-valias=y --enable-auth-logging=y --enable-passwd=n --enable-logging=p --enable-defaultquota=10000000S --enable-many-domains=n --enable-valias=y --enable-mysql-logging=y
loading cache ./config.cache
           vpopmail 5.2.1
            Current settings
vpopmail directory = /home/mail
               uid = 89
               gid = 89
          ip alias = OFF --enable-ip-alias-domains=n (default)
address extentions = OFF --enable-qmail-ext=n (default)
     roaming users = OFF --enable-roaming-users=n default
        user quota = 10000000S -enable-hardquota=10000000S
       auth module = mysql --enable-mysql=y
 mysql replication = OFF --enable-mysql-replication=n default
table optimization = one domain with many users --enable-many-domains=n
  system passwords = OFF --enable-passwd=n default
      file locking = ON  --enable-file-locking=y default
         file sync = OFF --enable-file-sync=n default disable vdelivermail fsync
      auth logging = ON  --enable-auth-logging=y default
     mysql logging = ON  --enable-mysql-logging=y
      clear passwd = ON  --enable-clear-passwd=y (default)
 valias processing = ON  --enable-valias=y
        pop syslog = show failure attempts with clear text password
    default domain =  --enable-default-domain=
          auth inc = -I/usr/include/mysql
          auth lib = -L/usr/lib/mysql  -lmysqlclient -lz

Reply via email to