Hello everyone,

I'm trying to convert several virtual domains using cdb (mostly encrypted passwords) into MySQL as I'm moving all domains to a new mail server using MySQL authentication.
I use vpopmail 5.2.1. vpopmail is configured to use the database "vpopmail" and user "vpopmail" in the vmysql.h configuration file.

The problem is that when I run "vconvert -c -m yourplana.com" nothing really happens with the vpopmail database. Everything seems to be ok and vconvert returns "converting yourplana.com done".

But, there's no additional table(s) added in the database "vpopmail":

mysql> show tables;
| Tables_in_vpopmail |
| vpopmail |

And there's nothing in the vpopmail table:

mysql> select * from vpopmail;
Empty set (0.00 sec)

If I add a domain using ./vadddomain yourplana222.com the postmaster user is created in the vpopmail table and it also creates two new tables called "dir_control" and "lastauth". I have tried to run vconvert for yourplana.com again, but that doesn't help either.

I have tried to run ./vconvert -c -m without specifying a domain name. Vconvert then runs through the entire list of domains in /home/vpopmail/domains and actually deletes the yourplana222.com domain I created a few minutes ago(!) The vpopmail table is now empty again. (At least this rules out any database connection problems.)

Doesn't vconvert support encrypted passwords in the vpasswd.cdb file, or are something wrong with my intallation?

I have configured vpopmail with the following options:

Any suggestions are very much appreciated.



Reply via email to