I would suggest you go back to your vpopmail source dir and run the
following :

make clean
then run your configure again
and then make install-strip

Perhaps you did the original setup in the wrong sequence.
You must make sure you modify the vmysql.h file 1st before you do all the
other steps

Michael.

----- Original Message -----
From: "System" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Cc: <[EMAIL PROTECTED]>
Sent: Thursday, June 05, 2003 5:15 PM
Subject: [vchkpw] could not connect to mysql update server Access denied for
user


> Hello All,
>
> I have installed vpopmail on my redhat 7.3 box with mysql 4.x and qmail
with
> SquirrelMail 1.0.4.
>
> I compiled vpopmail and used the following settings for mysql.
>
> /usr/sbin/groupadd -g 89 vchkpw
> /usr/sbin/useradd -g vchkpw -u 89 vpopmail
>
> GRANT select,insert,update,delete,create,drop ON vpopmail.*
> TO [EMAIL PROTECTED] IDENTIFIED BY 'vpoppass';
>
> pico vmysql.h
>
> /* Edit to match your set up
> #define MYSQL_UPDATE_SERVER "localhost"
> #define MYSQL_UPDATE_USER   "vpopuser"
> #define MYSQL_UPDATE_PASSWD "vpoppass"
> */
>
> #define MYSQL_READ_SERVER   "localhost"
> #define MYSQL_READ_USER     "vpopuser"
> #define MYSQL_READ_PASSWD   "vpoppass"
> /* End of setup section*/
>
> /* defaults - no need to change */
> #define MYSQL_VPORT 3306
> #define MYSQL_DEFAULT_TABLE "vpopmail"
> #define MYSQL_DATABASE "vpopmail"
> #define MYSQL_DOT_CHAR '_'
> #define MYSQL_LARGE_USERS_TABLE "users"
>
> here are my Configure options
>
>
./configure --enable-roaming-users=n --enable-default-domain=mydomain.com --
>
[EMAIL PROTECTED] --enable-logging=p --enable-defaultquo
>
ta=20971520S --enable-ip-alias-domains=n --enable-passwd=n --enable-clear-pa
>
sswd=n --enable-domain-quotas=n --enable-mysql=y --enable-incdir=/usr/includ
>
e/mysql --enable-libdir=/usr/local/lib/mysql --enable-many-domains=n --enabl
>
e-auth-logging=y --enable-mysql-logging=y --enable-valias=y --enable-mysql-l
> imits=n
> make
> make install-strip
>
> The above process works just fine. and even i have checked my mysql user
and
> pass this is also fine.
>
> But after compiling my database vpopmail remains empty (without any table)
> Why ?
> when i execute /home/vpopmail/bin/vadduser [EMAIL PROTECTED] "pass" it
gives
> an error :
>
> could not connect to mysql update server Access denied for user:
> '[EMAIL PROTECTED]' (Using password: YES) with database
> could not connect to mysql update server Access denied for user:
> '[EMAIL PROTECTED]' (Using password: YES)
>
> Why does it takes root if i am using vpopuser for the mysql connection.
>
> Please put on the correct path as i have googled a lot and also search but
> could not found any info that will help me in this context.
>
> Regards,
> Tina.
>
>
>
>
>


Reply via email to