Thank you very much for your advice. I tryed your advice. But there's perhaps no concept of ld.so.conf in BSD Please refer the following URL. http://www.my-opensource.org/lists/myoss/2002-04/msg00034.html
I ask about OpenBSD3.2 user. "/var/run/ld.so.hints" file is binary file.
LDCONFIG(8) OpenBSD System Manager's Manual LDCONFIG(8)
NAME ldconfig - configure the shared library cache
SYNOPSIS ldconfig [-RUmrsv] [directory ...]
ldconfig is used to prepare a set of ``hints'' for use by the run-time
linker ld.so to facilitate quick lookup of shared libraries available in
multiple directories. It scans a set of built-in system directories and
any directories specified on the command line (in the given order) look-
ing for shared libraries and stores the results in the file
/var/run/ld.so.hints to forestall the overhead that would otherwise re-
sult from the directory search operations ld.so would have to perform to
load the required shared libraries.
The shared libraries so found will be automatically available for loading
if needed by the program being prepared for execution. This obviates the
need for storing search paths within the executable.
The LD_LIBRARY_PATH environment variable can be used to override the use
of directories (or the order thereof) from the cache or to specify addi-
tional directories where shared libraries might be found.
LD_LIBRARY_PATH is a `:' separated list of directory paths which are
searched by ld.so when it needs to load a shared library. It can be
viewed as the run-time equivalent of the -L switch of ld.
ldconfig is typically run as part of the boot sequence.
The following options are recognized by ldconfig:
-R Rescan the previously configured directories. This opens the hints file and fetches the directory list from the header. Any additional pathnames on the command line are also processed.
-U Unconfigure directories specified on the command line or remove
inaccessible directories from search path if no directories spec-
ified. This option cannot be used with -m.
-m Merge the result of the scan of the directories given as argu-
ments into the existing hints file. The default action is to
build the hints file afresh. This option cannot be used with -U.
-r List the current contents of ld.so.hints on the standard output.
The hints file will not be modified.
-s Do not scan the built-in system directory (``/usr/lib'') for shared libraries.
-v Switch on verbose mode.
Special care must be taken when loading shared libraries into the address
space of set-user-Id programs. Whenever such a program is run, ld.so will
only load shared libraries from the ld.so.hints file. In particular, the
LD_LIBRARY_PATH is not used to search for libraries. Thus, the role of
ldconfig is dual. In addition to building a set of hints for quick
lookup, it also serves to specify the trusted collection of directories
from which shared objects can be safely loaded. It is presumed that the
set of directories specified to ldconfig are under control of the sys-
tem's administrator. ld.so further assists set-user-Id programs by eras-
ing the LD_LIBRARY_PATH from the environment.
SEE ALSO ld(1), link(5)
A ldconfig utility first appeared in SunOS 4.0. It appeared in its cur-
rent form in NetBSD 0.9a.
OpenBSD 3.1 October 3, 1993
1. you arent supposed to run "/var/www/cgi/qmailadmin" in the console, open it from through the webserver & browser
2. look for the file called "ld.so.conf" and add "/usr/local/mysql/lib/mysql" to the bottom of it (on linux its in /etc/ld.so.conf)
3. then run ldconfig
and try opening the file in through the website again (im used to doing it on linux, so it might not be the exact same)
At 05:05 PM 6/6/2003 +0900, you wrote:
My system is the following. OpenBSD 3.2 Apache-2.046 qmail-1.03 qmailadmin-1.0.6 vpopmail-5.2.1
I built above system. but I have a error. I performed the following command.
- - - - /var/www/cgi/qmailadmin /usr/libexec/ld.so: qmailadmin libmysqlclient.so.12.o: No such file or directory - - - -
I have libmysqlclient.so.12.o in /usr/local/mysql/lib/mysql. although I reboot OpenBSD, I want to remain library path.
Thank you in advance.
Cream[DONut] - www.donut.dk www.nethouse2000.dk - admin