> The problem is actually related to the permissions on the /etc dir.

Right.  I figured that out after I posted.  I was running tcpserver as
vpopmail and trying to write to /etc  (Actually, vchkpw was, I didn't really
care if it updated tcp.smtp)

> Now if you want to go with the database patch that Matt Simerson
> has... You
> need to use the -X option in your tcpserver line instead of the -x which
> uses the tcp.smtp file.

Ah. I have not gotten that far, but you're right, I remember that now.

> The patch is applied to tcpserver, but not to vpopmail which still
> recompiles tcp.stmp.cdb on each iteration... So I believe that is what is
> causing your problem.

I actually solved this by recompiling vpopmail and defining the tcpserver
file in /home/vpopmail/etc/tcp.smtp -- this fixed it, and I set the
permissions back to vpopmail:vchkpw in the script spawning tcpserver for
pop3d.

That is solved.  Here is what I am confused with.  In the INSTALL file for
vpopmail 5.2.1 in item #13 it says:

"For sites using the mysql module and --enable-roaming-users=y it is highly
suggested to use Matt Simersons tcpserver-mysql patch. This removes the need
for vpopmail to compile a tcp.smtp.cdb file for each pop authentication.
Instead, tcpserver looks directly into the vpopmail mysql table of IP's."

So, my question is, since I compiled with mysql and roaming users enabled,
and since I intend to fully utilize the patch, how do I tell
vchkpw/tcpserver to stop compiling the cdb file with EAHC pop
authentication?

I know its a small concern.  It won't hurt anything.  But this paragraph
suggests that you can eliminate the overhead of running tcprules on this
file every time someone successfully authenticates, and I'd like to do that
due to the high volume of POP requests I'm dealing with.

Is there a configure option i'm missing or is the documentation simply
talking about "the need" and not suggesting that its possible to disable the
recompile step that is now not needed at all?

-jeff


Reply via email to