At 16:21 15/06/03, David Choo wrote:
Dear All,

I'm currently running Qmail 1.03 + Vpopmail 4.9.10 + Courier IMAP 1.3.81
+ qmailadmin 0.45 + Sqwebmail 2.0 Combo with CDB authentication.

I setup a test machine with vpopmail-5.2.1 using CDB authentication in
office and tried to upgrade. I did the following steps in an attempt to

[EMAIL PROTECTED] vpopmail-5.2.1]$ make clean
[EMAIL PROTECTED] vpopmail-5.2.1]$ ./configure (with orig options) +
[EMAIL PROTECTED] vpopmail-5.2.1]$ make
[EMAIL PROTECTED] vpopmail-5.2.1]$ make install-strip
[EMAIL PROTECTED] vpopmail-5.2.1]$ vconvert -c -m

It tells me done for everything. However, when I tried to login using
POP3 access, my password was wrong. Only when I changed the user
account's password then did the login work. Somehow, I feel that the
vconvert program does not convert encrypted passwords correctly, or
totally do not convert at all.

As such, I would like to ask if there is anyway to convert encrypted
passwords from CDB - MySQL?

I asked a question similar to this recently and was told that, no, vconvert can't read the password encryption method for vpopmail 4.9.10. If you know your users' passwords you could write a script to first do `vpasswd user passwd`, then run vconvert. AFAIK there is no way to get vpopmail 4.9.10 passwords into clear text for conversion. I would love to be proved wrong, however.

Lou Hevly
Manresa, Catalonia

Reply via email to