vpopmail 5.3.20 from FreeBSD ports collection. it *was* a cdb based setup and I've recently moved from cdb to mysql. (it's much faster and went seemingly easy.. but)

[EMAIL PROTECTED] [~]# 11 > telnet localhost 110
Connected to localhost
Escape character is '^]'.
user user
pass pass
vmysql: sql error[3]: Table 'vpopmail.users' doesn't exist
-ERR authorization failed
Connection closed by foreign host.

and yes it's true the users table does not exist in the mysql vpopmail database, also when people with virtual domains try and login as postmaster from an alias'd domain it gives them a simmilar error.

This is what I have from a make configure:

           vpopmail 5.3.20
            Current settings

vpopmail directory = /usr/local/vpopmail
               uid = 89
               gid = 89
          ip alias = OFF --enable-ip-alias-domains=n (default)
address extentions = ON  --enable-qmail-ext=y
rebuild tcpserver file = YES  --enable-rebuild-tcpserver-file=y (default)
     roaming users = ON  --enable-roaming-users=y
    tcpserver file = /usr/local/vpopmail/etc/tcp.smtp
    open_smtp file = /usr/local/vpopmail/etc/open-smtp
        user quota = 1048576S -enable-hardquota=1048576S
     domain quotas = OFF --enable-domainquotas=n (default)
       auth module = mysql --enable-mysql=y
 mysql replication = OFF --enable-mysql-replication=n (default)
table optimization = one domain with many users --enable-many-domains=n
  system passwords = ON  --enable-passwd=y
      file locking = ON  --enable-file-locking=y (default)
         file sync = OFF --enable-file-sync=n disable vdelivermail fsync
     make seekable = ON  --enable-make-seekable=y (default)
      auth logging = ON  --enable-auth-logging=y (default)
     mysql logging = ON  --enable-mysql-logging=y
      clear passwd = ON  --enable-clear-passwd=y (default)
     users big dir = ON  --enable-users-big-dir=y (default)
 valias processing = ON  --enable-valias=y
      mysql limits = OFF --enable-mysql-limits=n (default)
        pop syslog = show failure attempts with clear text password
    default domain =  --enable-default-domain=
          auth inc = -I/usr/local/include/mysql
          auth lib = -L/usr/local/lib/mysql  -lmysqlclient -lz

mysql> show tables;
| Tables_in_vpopmail         |
| dir_control                |
| lastauth                   |
| limits                     |
| relay                      |
| valias                     |
| vlog                       |

this is a result of show tables; with my domains removed. (there are about 45-50 of them)

Clues or suggestions would be -greatly- appreciated.

Reply via email to