> hi all,
>
> I have been having a qmailadmin problem for a while now, after playing
with
> vpopmail I think I have got to the bottom. (quite a simple one when you
look
> at it properly)
>
> The initial problem was qmailadmin gave me the error "could not open" and
> that was it
>
> I rebuilt qmailadmin - I rebuilt vpopmail nothing seemed to work.
>
> However I tried to add a domain using the command line today as I decided
to
> spend some proper time on this problem.
>
> I ran a ./vadddomain test.com
> typed in the password 2 times
> and got back "Error: Could not open qmail default"
>
> a quick search of bluedot.net revieled that qmail default is
.qmail-default
> in the domain dir of the domain creating.
>
> so the problems is a simple permissions problem. Now comes to the
confusing
> bit.
>
>
> All the domains bar inter7.com and hugo.com where created from the first
> vpopmail install
>
> [EMAIL PROTECTED] /home/vpopmail/domains]# ls -la
> total 44
> drwx------   10 vpopmail vchkpw       4096 Sep 21 15:13 .
> drwxr-xr-x    9 vpopmail vchkpw       4096 Sep 10 20:21 ..
> -rw-r--r--    1 vpopmail vchkpw         34 Sep  9 10:12 .dir-control
> drwxr-x---    3 vpopmail vchkpw       4096 Apr 23 13:24 aspectevents.co.uk
> drwx------    4 vpopmail vchkpw       4096 Jul 17 14:15 hacktek.co.uk
> drwx------    2 vpopmail vchkpw       4096 Sep 21 15:06 hugo.com
> drwx------    2 vpopmail vchkpw       4096 Sep 21 15:13 inter7.com
> drwxr-x---    4 vpopmail vchkpw       4096 Sep 10 20:08 mdlan.co.uk
> drwxr-x---    4 vpopmail vchkpw       4096 May 29 17:08
> parsonsmotorsport.co.uk
> drwxr-x---    6 vpopmail vchkpw       4096 Apr 30 15:38 projecthugo.co.uk
> drwxr-x---    4 vpopmail vchkpw       4096 Apr 25 15:15 sfproject.co.uk
>
> As you can see the X permissions is missing from the group permissions on
> the 2 test domains created. So vpopmail is actually creating the domains
> with the right user/group vpopmail:vchkpw (so the ./configure options
appear
> to have worked)  yet it appears to have just forgot about the group
> permissions ???
>
> The group permissions at not a build time option ?? so why when I have
> rebuilt the same version of vpopmail with the same configure options does
it
> simpley forget to apply group permissions. vadddomain creates the dir with
> the wrong group permissions so it can't create the .qmail-default domain
> inside.
>
> Any suggestions as to why vpopmail is doing this ?
>
> (Thanks for the input on the qmailadmin list also some good advice - the
> fact that I didn't get anywhere made me get my head down today)
>
>
> thanks,
>
> Matt.
>



Reply via email to