I am not an expert when it comes to roaming users, but I have a few
suggestions/notes for you :

If you are using Matt Simerson's tcpserver patch, then I would imagine that
you wouldn't use the "-x /path/tcp.smtp.cdb" switch in the tcpserver run
script (because this information is stored in MySQL by the -S switch)

IMAP-before-SMTP is hardcoded off in all the recent versions of courier-imap
The reason for this is documented here :
<http://www.mail-archive.com/[EMAIL PROTECTED]/msg14184.html>
If you want to try and enable it, you need to tinker with the
HAVE_OPEN_SMTP_RELAY flag in authlib/preauthvchkpw.c

I believe you cant do IMAP-before-SMTP if you are running courier
--with-authdaemon. This functionality only works if you compile
courier --without-authdaemon.  I see your configure included
--without-authdaemon, so you should be safe from this issue.
(I thought I would mention it for the list archives in case anyone
else runs into this particular issue)

Here is a link for a bit more documentation about the two courier-imap
issues mentioned above :
<http://sourceforge.net/tracker/index.php?func=detail&aid=796524&group_id=85
937&atid=577801>

And as someone else has already suggested, SMTP-AUTH
(rather than pop-before-smtp/imap-before-smtp) is becoming
an increasingly popular way to allow users to roam

Hope that helps

Michael.

----- Original Message ----- 
From: "Joseph Kacmarcik" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Thursday, September 25, 2003 1:14 PM
Subject: [vchkpw] mysql relay table frustrations


> hi list!
>
> so... i've read a number of posts, looked in a number of places, compiled
> and recompiled numerous times, but i can't get qmail/vpopmail/courier on
> linux to write to an sql relay table. everything works except this part. i
> can authenticate and receive via pop or imap, and either over ssl. i can
> send using webmail on the local system.
>
> i used the same patches and the same configure concoctions to compile the
> same software on two different freebsd boxes and it works fine (please
> don't ask why i don't just use the bsd boxes).
>
> so, here's my configure lines:
>
> no patches to vpopmail. i started with 5.3.23 and am on 5.3.27 now with
> the same results
>
> /usr/local/src/vpopmail-5.3.27
> ./configure --enable-mysql=y --enable-roaming-users=y \
> --enable-defaultquota=1073741824S,100000C --enable-learn-passwords=y \
> --enable-logging=p --enable-mysql-logging=y --enable-qmail-ext=y
>
> no patches for courier imap. started with 2.1.1, am using 2.1.2 now.
>
> /usr/local/src/courier-imap-2.1.2
>
./configure --prefix=/usr/local --exec-prefix=/usr/local --without-authldap
\
> --without-authshadow --with-authvchkpw --without-authcram \
> --sysconfdir=/usr/local/etc/courier-imap \
> --datadir=/usr/local/share/courier-imap \
> --libexecdir=/usr/local/libexec/courier-imap \
> --enable-workarounds-for-imap-client-bugs --disable-root-check \
> --without-authdaemon --with-redhat
>
>
> my qmail-smtpd startup is: (variables are handled in the script)
> exec softlimit -m 8000000 tcpserver -S -R -H -c100 -x
> /usr/local/vpopmail/etc/tcp.smtp.cdb -u $QMAILUID -g $NOFILESGID 0 smtp
> qmail-smtpd salo.chubbo.net /usr/local/vpopmail/bin/vchkpw /usr/bin/true
> splogger smtpd
>
> have tried removing path to tcp.smtp.cdb too.
>
> /var/qmail/control/sql
> server localhost
> port 3306
> database vpopmail
> table relay
> user vpopmail
> pass password
> time 1800
>
> ~vpopmail/etc/vpopmail.mysql
> localhost|0|vpopmail|password|vpopmail
> localhost|0|vpopmail|password|vpopmail
>
> i'm logging mysql traffic for debugging and i don't see any inserts into
> the relay table, only selects and deletes (from cron).
>
> ucspi was patched with mr simerson's ucspi-tcp-0.88-mysql3+rss.patch
> although i have tried ucspi-tcp-0.88-mysql+rss.patch with the same
> results.
>
> i really hope i'm stupid this year and it's a simple thing, but i can't
> figure it out.
>
> thoughts and helpful comments appreciated.
>
> thanks in advance!
> joe
>
>


Reply via email to