Did you setup the
  ~vpopmail/etc/vpopmail.mysql file?
eg
  echo "localhost|0|vpopmailuser|vpoppasswd|vpopmail" >
~vpopmail/etc/vpopmail.mysql
  chown vpopmail.vchkpw ~vpopmail/etc/vpopmail.mysql
  chmod 644 ~vpopmail/etc/vpopmail.mysql

Also note, the output of "./configure --help" is faulty with respect to
the --enable-tcpserver-file
This option needs to be done like this :
  --enable-tcpserver-file=/home/vpopmail/etc/tcp.smtp
rather than this
  --enable-tcpserver-file=~vpopmail/etc/tcp.smtp

Michael.

----- Original Message ----- 
From: "SÚrgio Manuel Rosa" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Thursday, October 16, 2003 10:42 AM
Subject: [vchkpw] vpopmail-5.3.28 + mysql 4.0.15 problem


> Hi all,
>
> I'm having this messages when I do a ./vadddomain xpto.com
>
> [EMAIL PROTECTED] bin]# ./vadddomain xpto.com
> Please enter password for postmaster:
> enter password again:
> vmysql: sql error[c]: MySQL server has gone away
> vmysql: sql error[b]: MySQL server has gone away
> Failure while attempting to remove_line() the locals file
> vmysql: sql error[c]: MySQL server has gone away
> vmysql: sql error[c]: MySQL server has gone away
> vmysql: sql error[b]: MySQL server has gone away
> Error. Failed to add domain to assign file
> Error: Could not update file
>
> When I try to create it again vpopmail screams that it's allready created,
> however no domain directory was created under ~vpopmail/domain/ .
>
> vpopmail was compiled with the following options:
> ./configure \
>  --enable-vpopuser=vpopmail \
>  --enable-vpopgroup=vchkpw \
>  --enable-tcprules-prog=/usr/local/bin/tcpserver \
>  --enable-tcpserver-file=~vpopmail/etc/tcp.smtp \
>  --enable-log-name=vpopmail \
>  --enable-roaming-users=y \
>  --enable-logging=p \
>  --enable-defaultquota=52428800 \
>  --enable-ip-alias-domains=n \
>  --enable-passwd=n \
>  --enable-clear-passwd=y \
>  --enable-domain-quotas=y \
>  --enable-mysql=y \
>  --enable-many-domains=n \
>  --enable-auth-logging=y \
>  --enable-mysql-logging=y \
>  --enable-valias=y \
>  --enable-mysql-limits=n \
>  --enable-relay-clear-minutes=30 \
>  --enable-domains-dir=domains
>
> mysql client and server are version:
> [EMAIL PROTECTED] vpopmail-5.3.28]# mysqld -V
> mysqld  Ver 4.0.15-standard for pc-linux on i686
> [EMAIL PROTECTED] vpopmail-5.3.28]# mysql -V
> mysql  Ver 12.21 Distrib 4.0.15, for pc-linux (i686)
> [EMAIL PROTECTED] vpopmail-5.3.28]#
>
> Vpopmail is version 5.3.28
>
> mysql database was created like this:
> mysql> CREATE DATABASE vpopmail;
> Query OK, 1 row affected (0.00 sec)
>
> mysql> GRANT select,insert,update,delete,create,drop ON vpopmail.*
>   -> TO [EMAIL PROTECTED] IDENTIFIED BY 'vpoppasswd';
>
> and I'm running REdHAt Linux 8.0 with the latest kernel, mysql is
> up&running.
>
> I found a post on this error but was related with different versions of
> server and client. What is missing around here?
>
> srosa
>
>
>
>


Reply via email to