Eduardo M. Bragatto wrote:

What do I need to know before upgrading from this version to that one?!
Is there any changes that I need to do about? I'm using CDB to store users/passes.


Eduardo,

A while ago I upgraded from 5.3.20 to 5.3.27 and recently to 5.3.28. The upgrade was easy and hassle-free. The only thing that kept me busy was the smtp-auth patch I applied to qmail-smtpd, and that's not vpopmail's fault. After the upgrade, I wasn't able to send out mail anymore, all I got were authentication errors. In order to authenticate with vchkpw, the program must be setuid root. After a "make install-strip", the newly installed version lost these rights. A simple "chmod 4755 ~vpopmail/bin/vchkpw && chown root.root ~vpopmail/bin/vchkpw" solved that.

Regards
Jochen




Reply via email to