X-Istence wrote:

Tom Collins wrote:

On Tuesday, October 21, 2003, at 09:11 AM, Trey Nolen wrote:

After upgrading to 5.3.29, we are getting the following error when trying to
add a domain:
Error: (vadduser) can't read domain limits

If you have a ~vpopmail/etc/vlimits.default file, it should work.

Ok, this seems to be a new requirement for 5.3.29 - after creating the file with the default values Justin mentioned in another mail, it works now for me, too.

I'll look into having the install process create that file if it doesn't already exist.

Good idea :)

Should we update the code so that it doesn't generate an error if neither .qmailadmin-limits or vlimits.default exist?

It shouldnt generate an error if either doesnt exist. As it would then make the admin freak.

I see three possible solutions:
- Creating the missing file with the default values (i.e. no limits) if it doesn't exist.
- Don't create the file, but don't complain about it either. Just use the default values as with before 5.3.29
- Throw an error message, and point out how to fix it (i.e. provide a vlimits.default-example file with the installation)

Also in your post about the new release, i suggest you take a look at the problems the person had, and see how those happened :)

That was me ;) As mentioned above, creating the vlimits.default file solved the problems for me, too.


Reply via email to